[Solved] Thunkable Live app crashing

Yes, even to me, the variables lose their value when change screen

2 Likes

I just sent out an update now; it should fix the frozen issue when there is a map component.

2 Likes

Thanks for the update @Ironchorch_Yo @Mikas_3D and @mattia.guariglia - delighted to hear that the Android version of Thunkable Live seem to be working for everyone.

The variables issues is a separate matter, we’re aware of it and actively working on it .

You can follow our progress over here:

Please feel free to leave a comment if you have anything to contribute!

Thanks.

2 Likes

Mine works fine now, thanks!

1 Like

I’ve just downloaded the latest iOS Companion (205-1). Appears to be working fine, no crashing. I’ll pop back if anything doesn’t work as expected.

2 Likes

Its still crashing. I tried every single solution told above like cash cleaning, closing opening, changing blocks, changing phone for android. I couldn’t take a simple step for two months in this platform. Somebody says something fixed, but it seems like everything mixed. For two years here, I have never faced with bugs and crashings like this before. Are we sinking?

Thanks @eoinparkinson - we’re just testing this ourselves at the moment, so far so good! :+1:


Hey @bymaho, really sorry to hear this. We’ve had a couple of days of hard work and bug fixes, but thankfully it looks like we’ve turned a corner. You mention you’ve been having problems with your apps for 2 months? The upgrade we did only came out in the last week so I’m not sure the two are related.

To get started, are you currently having problems with Thunkable Live? If so, is this on Android or iOS? And what version of the Live app are you using?

1 Like

Actually @eoinparkinson - can you try building an iOS app too if you don’t mind? The build servers should be updated now, so hopefully we can resolve this issue too!

1 Like

Ok, this seems to be working fine on iOS and Android now. I’m going to mark this as “solved” for now, because it seems that closing Thunkable Live and opening it back up again no longer cause a crash.

If you app is crashing for a separate reason, please create a separate topic, thanks!

cc: @badbrains @general_tonje @Mikas_3D @newman1994211pt @StartShare @Michael_Rogulla @LuEllaBella @rzkymochamadp2culj @maxb @spuradic.techa @eoinparkinson @ashwani.mathur3difzz @wagnerwillianx6 @ianphaas @David_Wolber @maptheunknown @s59jjycemkg5 @solveraplicativo @Balanced_Kitchen @roumak @apauaie @Ironchorch_Yo @doctorsof @gobassky @83c4d26aa4d240 @airjordan @lamagalhaes @Deluxe @penny @roumak @hernandezsilvaericko @lilly.jaden54v @cabel_apps @teerapat.dj @dro @sirfrancisdrake @apauaie @orgelman @athornock @hernandezsilvaericko @solveraplicativo @mattia.guariglia @ahmadafandi13fqvz @KaneoheKid @niniks @go1tentcjzwu @wikilinks.infooleua0 @general_tonje

1 Like

Hey @domhnallohanlon,

iOS Download

No crashing with downloaded app (iOS 14).

  • First launch there was an issue with my app not loading some valuable info correctly.
  • Second launch, everything appears to be working.
  • Third launch, everything also appears to be working.

Overall it looks good on my end. Will update if anything doesn’t work. It also appears that yesterdays issue for me with the “Download” button not working has been fixed.

Android Download

Sign In component on Android download (and live companion) still do not work. I believe this is an older issue that I was late to address. Sign In component does not return an error code. Back when I used v201 for Android, it returned invalid API Key.


Thanks for all the hard work on fixing everything, Eoin.

1 Like

Thanks for working really hard on this guys. This was really critical. I just tested the live app v205 on iOS 13.5.1.

  1. The app did not crash but the blocks didn’t run
  2. I closed the live app and opened again
  3. It did not crash and this time it ran the blocks.

I removed all blocks (except for 1 alert) in my app because of this issue so I’ll start adding all the blocks again and test more tomorrow.

Thanks!

1 Like

So for the Sign In Component, are you saying it won’t return an error code? is that the only problem? If you can share me a simple(st) app to demonstrate the issue, I can take a look during the weekend!

Best,
Wei

2 Likes

Thunkable Live iOS
Thunkable Live for iOS 13.6 is working on iPhone X
Sign in component is working correctly for me on iOS Thunkable Live.

Thunkable Live Android
The crash problem disappeared but the keyboard bug reimains there
image

Android Download
It stills crashing when the app is opened on Android 10
UPDATE
On second download, the app works almost perfectly on Android 10. On first launch the UI doesn’t loads well. Second launch works perfect.

iOS Download
iOS app works perfectly.

3 Likes

I have Android 6.0.1 … My app stopped when I open it. And among other things, In thunkable Live there is a bug with Airtable Get Row/Update row, the App crashes. Thanks.

(downloaded app)
i have some white screen problem (when i launched app at first screen goes white and nothing happen) in some screen (not whole screen). and if i shut down the app and re-launch it, then it works just fine (in both OS)

and still searching for which block causes the problem now.

but when i deleted that screen it works fine. (in Android for sure, iOS don’t know yet.

=> i don’t know why but if i have custom SPLASH screen, crush happen.

i mean, if there are no any block except navigate to other screen at first, it will crush.

(downloaded, Android, 205, Samsung)

Thanks for the thunkable live v205, its working pretty fine now.

1 Like

Hi @wei,

The sign in component doesn’t function. I cannot sign in on Android, though the same app with the same project works fine on iOS and web.

I tried to retrieve an error code but it returns nothing. About 3 weeks ago when I first noticed this, I got an invalid api key error, which again was only on Android.

I will send you the project link via dm if thats okay.

Thanks.

(edit)

Sign In component works for new apps https://x.thunkable.com/projects/5f1c111aa6e9dd643f68ee8e/bcf268c6-ebce-4069-bca8-58975388c315/blocks
This issue appears to be direct to me.

I’m working pretty good now, no animated gifs working on the android live app and lottie files have been removed, but other than those minor things, everything is working.

2 Likes

Sorry for late answer!!
my problems with live app login crash and buttons are solved (iphone 6 and ipad pro). Everything seems to be rolled back to some weeks ago!! thanks for the great effort!!

2 Likes