[Solved] App variables being defined on multiple screens

Hi, has anyone experienced problems with their app in the last 14h?

I tested my app at 11pm italian time(14 h ago ) and everything was working fine, this morning 9 am the same App wasn’t functioning anymore.

I tested also the functioning backups that I had and none of them is working anymore.

Do you have an explanation for this behaviour?

Hi @wikilinks.infooleua0 :wave:

I’ve been using Thunkable X all morning without issue. Just one thing I want to double-check with you…

Are you having issues with an app installed in your phone or are you having issues working on x.thunkable.com?

I’ve opened a ticket on GitHub, here there’s the description of the problem in detail:

I haven’t tested this too thoroughly but I would imagine, based on your screenshots and on your blocks, that the issue is probably here:

The get request is asynchronous so you need to wait, even .1 or .2 of a second for the first response before sending the next one. Using a loop like this will just fire off 15 get requests so by the time all your variables and labels are updated in the first iteration your loop counter has already sent 5 or 10 more get requests.

See if that makes a difference and let us know.



Not sure but my app is no longer working properly, my custom feed URL became undefined. Tried on a new app and became undefined as well

2 posts were split to a new topic: What is Error 521?

Same here. My app works fine in live mode, but not when I download and test it. Is this the same for everyone?

Same here.

I have the same problem. It is frustrating as I am due to launch my app this week, I have been going through hell for the past 2 days. At first, it was Android load that was broke. Then followed by on the Thunkable live. Then a day later, it happened on the iPhone download. And next was the iOS Thunkable live. It was like seeing all my months of effort sinking slowly.

Was there an update to the blocks and some not working now?

4 posts were split to a new topic: Issue with sizing on screen elements

the problem was the last update, now everything seems to work fine.

Awesome, this issue is now closed:

A post was split to a new topic: Error: App Version Name

A post was split to a new topic: Question about getting data from an Object?