[Solved] SetCell in Airtable


I am having a problem and hopefully someone could help me. I thought I knew the simplest things about airtable, but I realized I am not. I can read data from airtable, even images and so on… But there is something I can’t make it work.

The idea is the following: I want to create an application for teaching. One thing I want to do is that the student can make some back up in the server (airtable). Therefore, I tried to save data in a column for that student (one particular cell) but I am not able to do so.

As a testing purpose, I tried the following: I read all the columns with “name” in it, and find the row with a student’s name. It works. Then I store this position (row number for that student) in a variable (let’s say that student’s position is row #3). It works. Then I read one column from that student (so whatever column X from row #3) using GetCell. It works. Then I tried to change a column for that student (so whatever column Y from row #3) using SetCell. It doesn’t work. Does anyone know why?

I copy the corresponding block section, as well as the error I get.

By the way, yes, I can make a workaround by deleting that row and creating a new one with all the fields (I know how to do that and it works). But I find myself stupid doing so, and not what I consider it is more straightforward: replacing one specific cell. What am I doing wrong? Why I can read a cell but not write?

Thanks in advance.

EDIT: Just in case, yes, I double checked that “Corazones” exist and there is no typo in it :frowning:

I’m just a beginner with Thunkable, but I’ve been working mostly with reading and writing data from/to Airtable.
It looks like you have two errors - finding the cell and writing that data into the “Corazones” column. I’d try to separate the two issues like this:
First check what type of column “Corazones” is in Airtable - to see if can accept a simple number or text string - if it’s a lookup column, for example, it won’t work.
Then (in Airtable) I’d manually input data into the cell you want to write to and then (in Thunkable) get that data from the cell. This will tell you if the cell reference is working properly.
It’s also worth checking if there’s an issue with the character set - given the column names are in Spanish. I’d suggest you copy the column name in Airtable and paste it in Thunkable.
Then if all that is working I can see no reason why you couldn’t write to that cell as you are doing.

1 Like

Hi, I work alot on airtable too. Sometimes a hidden space in the front or/and the end of the column name is the culprit. And Shane is right to point out that the data type is also important, they must match (string, number, date/time, or object). Your read from the cell suggests “7,12,15” which seemed like a string, so you should upload a string.

1 Like

Thanks a lot for the replies :slight_smile:

I have just tried it and the problem is solved. As you both said, I need to add the value as a string. Although I swear that I tried it before posting :sweat_smile:

Thanks a lot once again!