Airtable/Thunkable acting weird calling cells

Hi there,

I’m facing the weirdest bug on Airtable ever. I’ve been struggling for the last two days on something really easy, and i deduced it’s a bug.

Blocks are way harder than these, but i looked for a solution and found out what blocks were causing problems:

Easy as you see it, when you click a button, it changes the name of the text, getting the value from an Airtable’s table cell.

Everything ok, the value has indeed changed to the word “si” but, when afterwards i manually change the cell from Airtable to the word “no” (as showed underneath)

When i click again, i’m expecting the button.text to change with “no”, but it’s not what happens; this is what i see:

I made different tries, spent literally a day but couldn’t figure out the problem.
Also i tried the checkbox (true/false) and to leave the cell empty (using the “is empty” component), but Thunkable doesn’t recognize the change of the cell.

It just works good if a restart the Thunkable Live and press the button again. But once that the button’s name has changed once, it won’t change again (like the example above)

To be added, i’m sure that this set of blocks were working pretty good before (about a couple of weeks ago), maybe it’s something related to a new release?
Problem is showing either with Thunkable Live on mobile and the one on the laptop.

Hope someone can help,

As always, thank you very much for your time.

1 Like


there’s definitly something wrong, i’m experiencing a similar problem but with different blocks, all related to Airtable’s update/set cells.

In this very easy block, it’s meant to add 1 to a value already set in an Airtable cell.
Like the problem i underline before, it just works one time: from 5 it gets to 6 but, when i try again it doesn’t work anymore.


The Airtable cell is set as number cell, so there is no mix between text and numbers, it should work also because it works the first time i click it.

I tried to delay the “set label_ClickRicevuti” but it doesn’t work either, but the most important thing is that the value in Airtable doesn’t change at all (at list not from the second time onwards)

I’m definitly in need of help here,
Looking forward for your kind reply

1 Like

Apparently this one has been fixed doing like this (posting the solution if someone will need in the future):

Using the Airtable component instead of the Data Sources ones:


1 Like

Hi is there any way i can contact to ask you some questions?

The get value block has an issue of getting values from the cache instead from the table direct. This is a known issue that comes and goes for the last year or so.