Airtable "toggle" button not working

I have a value in Airtable (formatted as “single line text”) that I want to toggle between a text emoji (“:1st_place_medal:”) and a blank string “”.

The blocks I’ve set up should check to see if the Airtable cell equals the emoji (app variable 1st edition symbol) and if so, change the cell value to a blank string. And if the cell does not equal the emoji, it should set the cell value to the emoji.

But when I test it, it always vibrates and runs the else section of the code. It doesn’t ever run the do section of the code even though I can see the value in Airtable changing to the emoji. If I repeatedly tap the Edit toggle button, it vibrates each time.

Is there perhaps some issue with storing an emoji text character/string in Airtable?

Edit: I tried using the string “1” in place of the emoji and it still updates the Airtable cell and acts as though it’s never equal to that value.

3 Likes

Ugh. Just realized I’m using Data Source blocks with Airtable when I probably should be using Airtable blocks. I’ve been through so many iterations of data sources with this project that I just kept using what I already had in my project.

Edit: that was it! I just needed to swap out the Data Source blocks for Airtable blocks.

5 Likes

Happens to the best of us tatiang!

4 Likes

I know you already solved it but I want to add some comments that might be useful to other members.

There is a problem with the get value block that it only works once and any subsequent call results in giving the cached value not the actual value in the data source.

You can use the Data Source connection for Airtable but you need to read the value with a different block that does not return cached values such as list of values.... or get row.

Using the StP becomes a bless in such situations because you can choose to connect to Airtable using the Data Source method or the Airtable component method, however, DnD does not have this Airtable component and using the buggy get value becomes a nuisance.

3 Likes

I appreciate that, @muneer.

@jared is this something the team is aware of and working on?

1 Like

Hmm. I’m not sure I’m familiar with this myself. Do either of you @tatiang or @muneer (or anyone else) have a simple working example that shows this behavior?

From the sounds of it, you’re getting cached data and not live data always? In an ideal world, since Airtable doesn’t offer webhooks to automatically alert the app, how frequently would your app callout to the data source to check for updates when airtable is a datasource you are using. We cache data to keep things snappy for your users. However, the GET block IMO should get a fresh value every time.

1 Like

This is another old issue.

In this post

The member is having the same issue with a Google sheet Data Source due to the same get value block.

You can see @cassandra acknowledging it and promising to look into it.

1 Like

Thank you! Let’s hold the team accountable today! :slight_smile:
In a friendly manner, of course! :laughing:

2 Likes