[Solved] Problem generating P12 for Onesignal / push notifications

I just tried to renew my push certificate for iOS with the Onesignal Provisionator tool and the tool in itself worked well but when I try to upload the new P12 from it to Onesignal and submit the password the provisionator tool gives me, I get an error stating that the password is wrong. I’ve tried at least 10 different times and it never works.

Any ideas? Any help?


An update on this: I reached out to OneSignal and they confirmed that they’re having issues with the provisioning tool and suggested me that I create the push certificate & corresponding P12 manually. They had instructions for this on Mac, but I have Windows, so I found instructions for that on here: Use openssl to create p12 certificate in windows for iOS push notification or distribution – A Turning Point

So, problem solved, needed some OpenSSL magic for the workaround. Took a while though. Hope this helps others too.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.