[Push Notification - iOS] Replace .p12 file after one year

Hi there,

i know that this is not 100% Thunkable reated but i am wondering if someone of you has experienced the same issue.

I’m using Windows and, after 1 year in Apple Stores, the app’s Push certificate usually expires and if I want to keep on sending push notification, it needs to be renewed.

At the moment it seems like the One Signal .p12 generator is not working (the support confirmed it), apparently it generates a .p12 file but with the wrong password that can’t be read from One Signal in order to replace the file.

I contacted the support and they gave me this link
to do it manually but, as you can see, it only works on Mac.

As I said i’m using windows and i having troubles extracting the .p12 file from the CRS (Certificate Signing Request) that i already created.

I know it sounds hard, but hope someone faced this issue before and can advise.

Thank you very much!

In the specific, i tried to follow these istructions but when i’m asked to extract in the .p12 format, the options are disallowed

I got to generate manually through this link: https://subscription.packtpub.com/book/application-development/9781849691383/1/ch01lvl1sec11/generating-a-certificate-signing-request-using-windows

On Windows, you’ll need these other 2 topics, from left side menu icon:
image

Resuming, it’s basically 4 steps:

  1. generate CSR with your apple developer e-mail account, name and country
  2. create new push services certificate on Apple Developer, then download it
  3. generate PEM file using certificate from step 2
  4. generate P12 file using PEM from step 3
2 Likes

Try using the OneSignal Provisionator on a INCOGNITO MODE (web browser). That worked for me.

1 Like

Thank both of you, i tried the incognito mode first and it worked

EDIT:

I knew i was speaking too early.
It worked for the first time, now even the incognito mode shows the same password problem.

The website you gave, doesn’t load properly (i tried different browers and incognito mode too) @assistsolucoes

OneSignal staff mentioned that from another computer would work. Not sure about that as per worked the first time on Incognito mode for me.

Sorry to know that, but it’s working for me… I opened just now.