iOS notifications missing [Oct 2 2022]

Hi

Ive published an app to testflight with push notifications enabled via OneSignal
These were working fine then dropped off and stopped working.

When you go into iOS Settings > Notifications the app is not listed. The app settings is also missing notifications.

I restored an earlier build and the notifications were in fact there.

I’ve reissued the Apple certificates etc and no difference,

Here are some screenshots attached. OneSignal SDK shows:

  • Make sure to call registerForPushNotifications if you have disabled auto prompting.

It seems the app build must be turning off notifications some how? any ideas

Previous build iOS app settings:
image

New build iOS app settings:
notifications missing

1 Like

Same problem here!
Have you found any solution?

Hey Tristan

I found a work around, but not a solution. I think there is a bug in Thunkable TBH, as this feature was working on an earlier build, then stopped abruptly without any changes. Support where pretty useless.

How I resolved was:

  • Logged into oneSignal website and created an ‘In-app message’ for my app. This was set to display a push notification upon first run that asks users if they want to enable push messages with an action button.
    image

-I Set the action button to ’ push notification prompt’
image

3 Likes

I’m noticing the same problem now too. Very frustrating

Hey everyone, sorry to see that this issue is happening. I’ll get this reported to our engineering team today.

@tristan.bonnotparent @chay @fastasarocket Would you all mind DMing me or replying with a link to your projects that are having this issue so that I can pass them along to engineering? TY!

I am also having this issue

I also have the same issue. Has this been resolved @conroy ?

Hi @Tommaso, unfortunately not yet. If you want to DM me a link to your project, I can include that in our bug report for our engineering team.

Thanks!

Thanks @conroy. When we can expect to have this issue fixed? Is there any timeline?

1 Like

Same problem here. As I finally solved how to make my own P12 without the OneSignal provisioning tool and got my app approved on the App Store, I discover that the push notifications don’t work anymore due to this bug. Nice.

Indeed, @conroy, would be nice if this was sorted soon. And please post here when it is. Thanks!

Yes me too @ethosworkfi!

@conroy please could you confirm that the push notification should also work well with TestFlight? I am testing from time to time to see if this solved.

In any case, it would be good if you could just confirm when this is fixed. Thanks!

1 Like

Yes, push notifications should work in TestFlight.

Hold up - are you saying apple won’t approve an app if the p12 certificate was made using the oneSignal provisionator tool?

No, the provisionator tool is good for Apple – when it works. The trouble is that it wasn’t working a few days ago when I tried to use it. After reaching out to OneSignal they confirmed me that they’re currently having issues with it and directed me to create P12 manually, which I then did.

@ethosworkfi @Tommaso If you’re experiencing what you also think is part of this issue, go ahead and DM me a link to your projects–the more examples I can get, the more likely I will be able to get our engineering resources available to work on getting a permanent fix.

For now, @chay’s workround iOS notifications missing - #3 by chay above will be your best bet for getting this notifications working again.

1 Like

Just sent you a link via DM. I don’t know what’s mission critical for the team but to me missing iOS notifications is pretty high on the list (even though there’s this workaround). Hope this would get fixed soon. Thank you!

By the way, meant thank you @chay for coming up with the workaround. It’s better than nothing. :slight_smile:

Thank you so much. This worked.

Hi All, this post is more than 1.5 months old. @conroy has this issue with push notifications been solved?

Thanks!