[Solved] iOS App crashes because of App Tracking

Hi there,

My iOS app has been rejected, I got the followings from the Apple Review Team:

Could you guys have a look at the crash report? The problem is that I can’t reproduce the crash, I tried on several devices.

@jane @domhnallohanlon @wei @Thunkable_Staff @Community_Testers

I was able to reproduce the crash on a friend’s Iphone XS with the following crash report:

crash.txt (109.3 KB)

Could you guys help me identify the cause of the crash? It will be very important as I can’t publish my app so. Thanks!

Hi there,

I did some more testing and got to the conclusion:

On iOS 14.6 everything worked great.

Updating the phone to iOS 14.7.1 the app crashes.

(iOS 14.7 was skipped)

Does anybody else facing the same issue?

I have found something about the crash message:

https://developer.apple.com/forums/thread/94817

1 Like

I have found the following line in the crash report:

It says a library crashed DUE_TO_PRIVACY_VIOLATION

What does that even mean?

1 Like

I know that this thread is 4 years old, but it might help identify the bug @Thunkable_Staff

It says:

The __CRASHING_DUE_TO_PRIVACY_VIOLATION__ crash happens whenever there is a mandatory permission string missing on the app’s plist. Permissions level are changed by Apple with new iOS versions sometimes. So code that was working will start breaking with iOS updates that have new requirements for the plists.

It might has something to do with Touch ID/Face ID, as in the new iOS there are updates to that as well:

1 Like

Well, not sure what I did, but I downloaded the app again and now everything works as expected, the app doesn’t crash.

I have filled these settings out, maybe that helped:

Thanks!

1 Like

I can confirm that this error was because of the Allow Apps to Request to Track property on the iPhones.

My AppId was missing in the AdMob Settings and having the Allow Apps to Request to Track property turned on, led to the error.

I had to enter the AppId and so the crash is gone.

1 Like