Apple: signal 6 error (again) publishing an update of the app

is the fourth time I receive an email like this from apple because they found the error 6 when they test the app and use the web viewer inside my app.

Guideline 2.1 - Performance - App Completeness

We’re looking forward to completing our review, but we are still unable to continue because your app crashed during review. Please review the details below and the attached crash logs, then complete the next steps.

Steps leading to crash:

  • app crashed when we tapped on the last button in the bottom menu

Review device details:

  • Device type: iPad
  • OS version: iOS 15.3.1

crashlog-74F3B0EE-904F-4897-AE49-205F5C4B5C26.txt (22.7 KB)

I don’t use add mobs or push notification but only: alert, sound, share, web viewer and camera (with the string in app setting this sentences: “Take a picture of yourself and put it in a sculpture”).

For the web viewer I left the Tracking Usage Description empty (i putted a space because when i tryed to put the sentence “This app accesses and Google Maps website. Your data may be shared with this website to facilitate functionality " the app was refused)

I**'ve already changed the settings of the privacy** in the apple page of the app.

Can you help?
@wei @jared

hey @trawellit ,

Following up here, can you leave the tracking string completely empty? instead of a whitespace leave nothing in the input

Retesting the app on the iPhone I got these results:

with Tracking Usage Description with white space = error signal 6

with Tracking Usage Description empty = signal error 6

with Tracking Usage Description with the phrase: “This app accesses and Google Maps website. Your data may be shared with this website to facilitate functionality” = I’m waiting To see

Since I’ve tried everything and set privacy on apple as suggested (only to analyze crashes), what should I do to get the app update accepted?

Do I have to remake completely the app?
Thank you

You shouldn’t have to remake the app completely. Thank you for trying all these different combinations.

I’m pinging our team, they should be coming online in the next couple of hours. I’ll keep you posted.

Do you know if some action has to occur on the app for the error to occur? Like, are they pressing a button to make this happen? Also, does this happen at all when you test this on your own devicee?

The error occurs when opening a web viewer.

In my app I have 3 web viewers in 3 different screens and in the various versions sent for review they went in crah 2 web viewer on 3: google my maps and a page of my site.

Previously (with Tracking Usage Description string full, empty, or just a space) the app worked by testing it on the iPhone.

Now it doesn’t work in the 2 cases mentioned and I have to test the third case.

I hope that the team can intervene because the question is very boring, especially because I change several factors but the result is always the same: signal 6, app crash.

Thank you

I tried the app by downloading it to an iPhone with the “Tracking Usage Description” filled with “this app accesses sites …” and it worked on the mobile.

I tried to load the same app on app connect and it gives me the error "Could not add to verification
The following items are required to begin the verification process:
Your app contains NSUserTrackingUsageDescription, which means you need to request permission to track users. To submit for verification, update your app Privacy response to indicate that the data collected by this app will be used for monitoring purposes, or update the binary code of your app and upload a new build ".

The privacy of the app has the section “I monitor data to check for crashes”.

Thanks for any help

Does this happen when you test the app on your device?

a couple of days ago not (if I remember well), now yes (on the 2 cases mentioned above).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.