Signal 6 was raised (null) with iOS 15

When Apple updated iOS 15 for their devices, I had a huge BUGS with Apple Reviewer, they reported the app had an error called Signal 6 was raised (null).

I tried to change the app content many times but still can’t fix it.

Through many tests, I found that the problem lies in the source code when Call Admob ads (it happens with both banners, interstitial and rewarded ads) the way to handle it is that Thunkable should check the source code when building an IOS app (which contains Admob), maybe you haven’t updated for a long time, and below are the details of the problem that I encountered.

Important Note: Apple Reviewer use:

Ipad, with IOS 15.0.1

The first time I used this block:

The second time I tried only Admob interstitial

The third time I use only Admob banner ads, it still had the same Signal 6 error.

Please Help me to fix this./.

Is there anyone who has the same problems as this?

1 Like

I believe your issue is in the AdMob settings.

Check this post.

1 Like

I’m sure it has nothing wrong with Admob settings, the post you just sent can’t be of any help to me. :frowning:

1 Like

Can you check your settings?

image

Make sure this option is switched off.

1 Like

But you specifically mention using AdMob in your app @handboyz9xxeh9e?

2 Likes

Oh yes, I got it.
When I Switched on this option, I opened the app then it appeared to crash called: Signal 6 was raised (Null), I think this is the main problem, Please help me how to fix if some users Switched this option on? Is there any way to make the Admob app run when Allow apps to request to Track turn on?

1 Like

Yes, there is a way.

We are waiting for Thunkable development team to fix the issue of the AdMob setting (the post I shared with you) and this will automatically fix this problem.

1 Like

Thank you very much, Sir.
Please note me when the Thunkable development team has finished fixing that ^^.
I feel so excited now!

1 Like

Hello, the issue is believed to be solved now. Can you check from your side?

1 Like

Hi there,

I tried when I got good news from you, there are 2 problems:

  1. I downloaded the IOS app with the Admob component and installed it on my iPhone 2 times with 2 apps, but it still crashed with “Signal 6 was raised”.

Do I need to send the app to Appstore?

  1. When I tried to create new apps I can’t add the Admob component, When I click on Ads components it went to a blank page (note: I tried in 2 systems: macOS and Windows 10)

I attached the video and browser console, hope it can help you to fix it.

https://drive.google.com/drive/folders/118wiBTxavMMEOOobUbv6JLZUUXlpbknh?usp=sharing

If you need any further information please let me know!

1 Like

Thank you for your feedback. Let me follow up and come back to you.

1 Like

Hi,

Have you guys made any progress in fixing the error?

Recently Google restricted ads on my Admob account, they said that I needed to Enable SKAdNetwork to track conversions. This is the error that the app produced by Thunkable encounters. Google has given instructions for handling, I would like to attach a link to how to fix it. Hope that can help you quickly fix the error!

https://developers.google.com/admob/ios/ios14?hl=vi

1 Like

Many thanks @handboyz9xxeh9e

I am putting it to the attention of @domhnallohanlon and @wei from the Thunkable platform.

Hi there,
It’s been almost a month since I reported the bug to the Thunkable team. I don’t know if you guys have made any progress in fixing the error? I am looking forward to receiving a good response from you.

1 Like

To @handboyz9xxeh9e thank you for waiting patiently.

To @muneer and the rest of the community:

Is anyone else experiencing this issue? In order to better troubleshoot issue it’s helpful to look at two apps experiencing this issue

1 Like

@jared
In my opinion there is no problem that is directly effecting the Signal 6 issue in iOS.

The actual problem is the app contains ads and the ads ID/Key is not saved in the project settings.

The main issue which is remained UNSOLVED is the ability to save the project settings as not all of it is saved.

However, for the time being just remember to supply the settings before publishing the app to avoid this issue from coming up.

The issue of some settings are not retained after closing the design page remains unsolved and once solved the user will not see the Signal 6 issue so if the developers in Thunkable solve this issue many users will feel relaxed.

2 Likes

The only way to fix an app is to push an update. So yes, if there was an issue it could be rectified.

To clarify here:

It sounds like people are experiencing an issue in which they enter some strings for adMob. It works. Then the make changes to the app, and then admob stops working. But, if you renter the values things start to work again?

Does that sound accurate? I want to have clear info to pass the engineering team and a project they can test with. Does this happen with all projects, DnD only or StP only?

1 Like

This is the practical workaround for the Signal 6 error at least until it is solved by the Thunkable development team.

As far as I am aware, @handboyz9xxeh9e has never complained about the adMob not working. His main complain is the Signal 6 issue from the start. The root cause of this issue is that project settings are not retained after closing the project.

He states it here there is an issue with the admob settings. @handboyz9xxeh9e are you still experiencing this or has your issue resolved itself.

Does your project work with no ads? I’m just wondering, I assume you Don’t want to publish without ads, but for trouble shooting purposes is why I ask that.

Do you know what settings aren’t saving? Is this a persistent or intermittent issue?

1 Like

You can easily test this. The settings are not being saved to everyone. This is an issue that was raised over a month ago and in some point it was said that it is fixed but it turned out that is wasn’t fixed.

The post that explains this issue (https://community.thunkable.com/t/admob-settings-not-saving/1537457) is deleted or merged with another post and cannot be found. You can see this post instead [Solved] Can't assign Camera and AdMob settings. Although this post says [Solved], it is actually NOT YET SOLVED.

Open any project, go to projects settings and type anything in AdMod App ID for both Android and iOS. Exit the project and open it again and check these settings again and you will see them empty.

iOS needs to track the apps and when this setting is not provided it will give the Signal 6 error.

That is the whole story.

Currently and until this is fixed, you have to remember to key in these values every time you want to publish the app.

I hope this clarifies the situation.

1 Like