Ads not showing in App

The banner Ads are showing in the test device
but not in the APP downloaded my device or the one uploaded to APPLE
somebody, please look into this

Hi @Mikas_3D,

Did you join our AdMob first?

Yes,
Ads show up in my other version just not showing up in my updates today

1 Like

I can’t access the database right now, but as far as I remember, you submitted multiple versions (with the word copy in the app title) of your project, right?

Are you sure you’re publishing the copy that was approved for download and not a newer/older copy you may have made for backup purposes?

I have since change the name from"copy" and made updates i had no issues with the same APP yesterday i made simple changes and upload a version for the ios store ads don’t show i also downloaded it from you guys and the banner ads don’t show

Can you PM me a copy so I can test on a device here?

the ads do show in the test but not after downloading i even turn off test mode to see if that as the problem

i have fix all my codes as best i could still getting
" Error Domain=com.google.ads Code=1 “Request Error: No ad to show.” UserInfo={NSLocalizedDescription=Request Error: No ad to show., NSLocalizedFailureReason=Request Error: No ad to show.}"

please some help is needed here it is working during test mode but once publish that is the error message.

no it not new ads code they over 2-3 weeks oldpublish ``testmode

3rd day still having this issue still waiting on help

1 Like

Did you message the admins on Intercom? The Chat service on the app editor page?

I also wonder if you’ve tried to PM an admin?

I also wonder if you’ve emailed support more than once?

i have done all i can at this point, well seems the error message is now showing up in testing which is something to work with towards fixing

seems to have worked it self out

2 Likes

the problem is back again i email admob they said could be an issue with SDK’s requirements
the APP is on Testflight sometimes ads show sometimes they dont with the error code i have done everything correctly on my end hence the ads show sometimes so its not my fault o please Thunkable look into your SDK’s requirements

1 Like

@domhnallohanlon I reported the same issue while back but no action was taken I’m getting the same issue

Report it on GitHub

how do i report it?

this is horrible i paying to be a pro member for this and 5% my add revenue for this ? horrible

2 Likes

That “try again later” is added by myself not the part of error

I know how you feel. And how do you report ? You report it by going to the link and submitting a “new issue” @Mark can you also look into this matter

i have taken the error block out of some tabs on the app but people going have to use it like that i am just losing ad money i could have gotten and all they say is ooh its error 1 its your fault not my fault!

1 Like

Go to view all issues then new and then report issue