[Solved] Can not publish to iOS, problem with NSUserTrackingUsageDescription which is not used

Unable to submit for review
The items below are required for the review process to start:
Before submitting this app for review, an administrator must provide information about the app’s privacy practices in the app’s Privacy section. know more
Your app contains NSUserTrackingUsageDescription, indicating that you will request permission to track users. To submit for review, update your app privacy response to indicate that data collected from this app will be used for tracking purposes, or update the app binary and upload a new build. know more

1 Like

Have you filled in all the relevant permissions in your project settings @wiselabr0x?

1 Like

Hi, thanks for you comments,
Yes, I think I did fill the relevant information but it keep replying that “the app contains NSUserTrackingUsageDescription, indicating that you will request permission to track users” even thought I do not use it. Is there any particular information I may have missed?
When installing the app from the TestFlight, it ask permission to use location but I’m not using GPS or similar.

1 Like

What components do you have in your project?

Are you using AdMob?

1 Like

no I’m not using AdMob. I use only Local_Storage, Bluetooth_Low_Energy, Timer and Alerts.

1 Like

BLE internally requires Location Services to be enabled and this could be the source of such alert.

I’ve just noticed that “This identifier will be used to deliver personalized ads to you.” is filled in on all my apps in the projects’ Tracking Usage Description fields. I’m not using any tracking components to my knowledge, and I never put this phrase into that field. I had the same problem with my iOS app being rejected, so I will remove and see if it goes through the second time.

… which it did not. So iOS is blocking my publishing an update. I get this message: Your app uses the AppTrackingTransparency framework, but we are unable to locate the App Tracking Transparency permission request when reviewed on iOS 15.1.

Please explain where we can find the App Tracking Transparency permission request in your app. The request should appear before any data is collected that could be used to track the user.

If you’ve implemented App Tracking Transparency but the permission request is not appearing on devices running the latest OS, please review the available documentation and confirm App Tracking Transparency has been correctly implemented.


Hi everyone
I am having the same issue with my app being rejected because of AppTrackingTransparency framework.
Any ideas?

@domhnallohanlon Hi Guys

I am having the same issue and it does seem that this has not been solved. I am not using Admob, GPS or similar. The Tracking Usage Description is pre filled in on Thunkable X, is it just a matter of leaving this blank and loading to Apple again. I noticed above that someone tried this with the same result.


Mine didn’t actually work when I removed that sentence, it was still rejected form the iOS App Store. But the Thunkable folks are aware and are looking at my three projects today and I hope they can figure out the problem by tomorrow.

I am also urgent as I have a calculation problem in a live App so very keen to get this sorted so I can upload a new version.
Thanks Thunkable Team

Hi @dlmetzgerbcch @carlinmclellan @towball

We just had this behavior mentioned to us yesterday, and we are checking it out.

Could you send me a message with these project URLs?


1 Like

Another question:
When did each of you last successfully publish an app to the App Store?

1 Like

My App was first published early August 2021.

I went through declaring that the App does have some tracking for crashes, updated the policy with a link to bugsnag.
It has now published and is in review.

I agree with the others that any tracking should be optional to us, the users of thunkable.

I think I have identified the cause of this behavior.
I’m waiting to hear back from Thunkable team member Jose on this issue.

I’ll post an update here when I get a reply from him.


OK, my idea was not correct.
The team is looking at this, I’ll still keep you guys updated on this issue.

1 Like

I had the same issue today.
My last successful publishing was Nov, 25th.

1 Like

UPDATE: emptying the Tracking Usage Description field, allowed me to send app to review.


Please let us know what they say! Our team is still actively working on this issue! Thanks for the update @lamagalhaes

1 Like