[Solved] "Device is Online" block disables all buttons on screen

I notice on the 17th of July the device online button freezes app it does not work
i have a data source and local data source and it render then useless along with any other buttons on the screen.
please fix this

Thanks

Do you mean the device is online block?

Screenshot 2020-07-21 at 10.50.13

Can you outline the steps to reproduce this error please?

Thanks.

1 Like

I keep on getting different blocks from my actual blocks when I launch. So, for example, I can not navigate to the next page with my iOS Live app because the blocks that it shows seem to have some funny numbers instead of the control to the next page so it won’t move yet on the laptop it works great. When I download the app it has the same issue as iOS Live app
See below

Live app Blocks

Actual Blocks

This started after I downloaded the update.
Please help!!!

2nd Question does anyone know how I can downgrade the app /

1 Like

yes spend alot of time yesterday to find out that device online conflicts with data source and will cause all buttons on the screen to not function.

in trying to figure out the problem I got a bigger problem with data source in my already publish app stop working because crazy enough I remove data source in the project file

i had to remove navigate to another screen if device offline i had the same issue

I think this bug iscomign Device Online blocks.
When i deleted Device Online Block it worked.

1 Like

After a couple of days trial and error, I realised that the block " device is online" is the cause rendering the app not workable, doesn’t matter where it was in the app. So I just remove it, and my apps seemed to work again. checking thru all the functions again and see which blocks do not work because my live-test app is still crashing randomly.

Thanks Doc, missed out your reply. I could have saved hours… :sweat_smile:

Hey @thanos-x - these “funny numbers” are just the component IDs, they’re needed to make renaming, cloning, working with the “Any Component” blocks etc. easier.

You typically shouldn’t be seeing these, but sometimes if you delete a component and then add the same type of component back in your will see references to the component ID like this.

Are you having any issues with the device is online? block though?

Really? I didn’t know about this. Do you have any samples that reproduce this behaviour please?

@domhnallohanlon Please check this topic “Device blocks - do not work!

Make a simple app put the device online button
One you will see that it causes all button the screen to not function that was my originally issue that i contacted staff about an in error i remove my data source. only to have my publish app crash then because of this crashing issue i am unable to update my published app which is non functioning since the 17th

Hello. I updated my app but if I use Thunkable Live my buttons do nothing when pressed. I downloaded the app both to Android and iOS and my buttons still do nothing. I only changed some images I did not change any block.

They are working as Web App but not on cellphones

UPDATE
I have other projects with the same login screens and the buttons stopped working too

What do you mean the buttons don’t work? They don’t change their labels? Do you use the “Any button Click” block? What version of Live do you use?

1 Like

that happened to me when i had if device is online do such
or just the if button

@actech No I am using normal buttons, they were working perfectly until I change the app icon haha. I do not know what happened. I have other 2 apps with the same structure and they stopped working too. I made to changes to those.

@Mikas_3D i will try by erasing the block

@Mikas_3D You were absolutely right. It was the the “If device is online” block. It was working good a few weeks ago. I do not know what happened. Thank you so much.

1 Like

Same in my App, it freezes when “device is onlne?” block is executed. Please repair this. Thank you a lot Harri

I delete device online blocks but still crashing test app. Directly closing. I delete test app And download again seeing same issue.
Why this bug didnt fix From Thunkable team

@Mikas_3D @thanos-x @hernandezsilvaericko @actech @Balanced_Kitchen @doctorsof @harri.f

Just by way of an update Just to keep everyone up to date with our progress - we’ve been able to reproduce this issue on our end and are looking into this at the moment. There’s a private Github ticket open for this at the moment and will keep you posted as we learn more.

Thanks.