[Solved] "Device is Online" block disables all buttons on screen

No, what you changed in your new update is obviously caused by a bug with it. You can find the source of the problem only if you focus on what you are updating. If it is a problem that cannot be solved, activate the old version until the problem is solved.
Thanks.

Thanks @doctorsof - we’re still actively working on a fix for this, but haven’t released anything yet.

We’ll keep everyone updated in this topic as soon as we ship an update for the “Device is Online?” Block.

Thanks!

Test app working well.
I didnt use device online block.
Is it working with in Ios?

“Device is Online” doesn’t work in Live ver. 205 on Android

ok…this thread is for users who are having issues with the Device is online? block.

Are you looking of the thread about Thunkable Live crashes? This has been fixed for Android and we’re just waiting on Apple to approve the update for iOS.

Thanks.


Thanks @actech - the update in v205 was specifically prevent crashes when Thunkable Live was closed and then re-opened.

We’re still actively working on the “Device is Online” issue.

working on a fix for Device is Online block!

As of yesterday, I noticed that all the blocks in the device group do not work!
PS: Android and iOS tests have been performed

test project: https://x.thunkable.com/copy/b54714377d48cb9e95621d8b121a59f8

Hey @Balanced_Kitchen, these look fine to me?

Can you share a screenshot of what it looks like for you please?

Thanks!

Would you test it on a device!
Live test or instal app.

Am I the only one facing this problem?

The problem occurs after updating the live test application. With the old version there is no problem with a live test, but after installing the test application the problem exists.

Does anyone have the same problem?
Why doesn’t anyone react?
However, there are over 15,000 new users. Where are you?

nothing been working 2 days now i was wondering if i am the only one

@Balanced_Kitchen, I’m going to merge your topic in with this one because (hopefully!) they are both part of the same thing.

Android companion v206 is on the Google play store and v205 is on the App Store.

For Android users, can you try out this companion v206?

iOS users, please try v205

Can anyone confirm if that fix the Device is Online issue?

@kizzy @thanos-x @hernandezsilvaericko @actech @Balanced_Kitchen @doctorsof @harri.f

3 Likes

I can confirm that the issue with the Device is Online block is fixed on 206.

1 Like

This did not solve it for me - i’m still experiencing the error.

I also get an error message from my WebAPI.
It returns the error that the target isn’t https - when it is could this be a clue?

Can you share a project link with us @orgelman so we can test this on our end?

Are you using Android or iOS?

Are you live testing or installing?

I’ve tested the livetesting on both ios and android. Is device online works in the Web-tester, but not WebAPI.
I’ve also downloaded the apk to andrid and it crashes right away.

https://x.thunkable.com/projects/5c6d276be7fadd8de2d26b6b/

Ok. it sounds like you’re having an issue with the WebAPI component? If that’s the case can you start (or bump) another topic please?

At the moment, in this topic, we’re trying to make sure that the Device is Online? block is working for everyone.

Is the Device is online? block working ok for you after the latest update @orgelman?

No - the Device is online? block does not work in the live testing-apps or the downloaded apk, but in web testing.

I included the WebAPI as a possible source of error…

Are you using v206 of Thunkable Live @orgelman ?