Misbehavior of android ThunkableLive v.279

Hello thunkers.
I feel like a bug explorer already :slight_smile:
Heres today issue for me, after installing ThunkableLive v.279.
Background: my app have multiple screens. After reaching a certain screen, ill have multiple butons there.
Pressing butons, will generate different actions. All working as expecting until here.
Pressing a certain buton will go thru some action that generates error:
Its ok, im still working on that, that is not the problem.
The problem is that after restarting the ThunkableLive, and try to acces that particular screen with unfinished buton (but with other buttons that are working well as i said before), ill get the same error again and again, even if im not accesing that buton. Error apears right on screen entry.
I did a “clear data/cache” of ThunkableLive, and the cicle repeats. First time when accesing that screen, all is fine, i get as expecting actions for good butons, but error on bad buton, trying to acces that screen again gets error until i clear data/cache again.
Same thing is happening with downloaded app aswell. Working only the first time, after clearing data/cache from system.

P.S. this is not something really bad as was local tables`s issue, cause i still can work with data/cache refresh, but is still something :thinking:

1 Like

Please share the Console with us, after hitting the Preview button.

(I am facing the same issue, contacted the Thunkable Team but no answer…)

1 Like

I just got a workaround:

  1. Save Screen to My Screens
  2. Add the screen again from My Screens
  3. Use the copied screen

I also have the same problem @domhnallohanlon please help us

This is usually caused by a lack of value in an object. Check your values!

You miss the point of my topic @Balanced_Kitchen :blush:
Is not the error that bothers. In fact i already solved that. Is the way that ThunkableLive acts. After error, if reset, it supposed to clear all and not displaying the same error when accesing that screen, even without pressing that buton. (solved only after i clear the ThunkableLive data/cache).

That’s weird. I’d encourage you to file a Github bug on it, but none of the bugs I filed two days ago have any staff response, so … shrug

1 Like