Cannot copy one of my project

Hello Thunkers,
I have no problem with my apps but one of them cannot be copied.
Would you see the problem and help me to fix it, please?


recently we encountered a similar problem. We could not find out the reason, but one of the image files, in any way, could not be removed from the project. Does your project have image files? Are you sure that you have not exceeded the account size in Thunkable X?


Did you solve your problem?

1 Like

I had to build a new one cos I cannot save what I do in last one any more.
Luckily, the last one has few downloads that’s why I am building the new one.
The last issue was with memory. Suddenly, it stops and says reload page because memory time.
But I face it again in the new one at the moment it works well and I hope that my new app never stops as the last one.
Cheers Alex!

Do I understand correctly that you have a browser, suddenly, it reloads Thunkable X with an open project and the last changes are lost? It’s very strange. Sometimes I notice such a Thunkable X reload, but it is not happening when working with the project and not associated with any messages regarding memory. Can you display an indicator of memory usage? Maybe somewhere it is leaking?

I was like this: if I load in text block too much data, Thunkable X just does not update the project in Live Thubkable and I see the old project.

And in our case it turned out: one attached to the project image file is frozen so that it is completely impossible to remove from the project, and Thunkable X is not allowed to perform any operation on the project. I had to do the project again.

1 Like

Almost I have the same issues. Some files are frozen and I cannot delete them and the next edit will not updated on live test.
About the memory issues, because the many blocks I work on the pop up message says “Memory time. Please, reload the page” I reload it and it return to the same project but I lost some newest blocks “in the new project” but it works fine after reload the page.
In the last project, I could not delete some files and add blocks but they have never been saved.
That’s why I started the new project.

“Memory time. Please, reload the page”. Does this message look like the one shown below?


I am using the latest updated Firefox and never seen this pop-up message.

In other browsers this message also appears? You said that you have big projects. Maybe you have exceeded the account limit is 200 MB? I had such excess, but after deleting heavy images, it works without problems.

1 Like

Yes it is. I have two projects on Thunkable x they are not more than 200 MB.
The app I talked to you about has many images but they are less than 20 MB.

Now my new project is stoped updating on live test as the old one.
Because this bloody pop up message.

No, 200 MB is a restriction not for the project, but on all projects in the account. Perhaps the sum of all your projects exceeds 200 MB.

Try it from your account to remove a few unnecessary but large projects. Perhaps the situation looks like this: you want to copy the project size of 15 Mb, and free space on your account only for 14 MB - the project won’t be copied.

Try to create a new account and copy your large projects into it. After that, memory problems disappeared?

1 Like

All projects are less than 100 MB. Cos they are only two.
I’ve deleted them and I will start again.

“Thunkable has increased app size limits to 50 MB per app” - can this be the reason?

You’re right, it would be interesting to hear from developers that literally does the message “Memory time. Please reload the page” and in what situations this may occur.

Maybe some of the resources you keep in storage, and not in the project? Sometimes I get projects with images whose weight which can reduce at least 2 times without appreciable loss of quality. 10 images is 1 Mb and it was possible to make = 500 KB.

1 Like

What do you mean “In the storage not in the project”?
As I add blocks the block screen get slower, Android classic was better in the memory.
I will make my pics as smaller as I can.
We do need an answer from admins @albert about the memory issues to avoid it next time.

I meant at design time to store a resource file in Cloudinary, Firebase, AirTable and the like. If the imported to project file of the image are frozen, apparently there is such a problem. The question arises, such a situation will repeat next time or not?

Of course, loading resources from remote storage requires online on the other hand, the project size is significantly reduced and there is no danger that the resource files will frozen.

1 Like

I did not use any firebase or cloud in my app.
The keeps crashing.
Thunkable sets 50MB for each app but it cannot load an app that 25MB on live test and the block screen will be so very slow.
Memory issue should be fixed.

Hello Alex, @actech @albert
I think I found out the issue of not updating live test or crashing it.
It’s about the Position of column.
If you set “JustifyContent” to “space-between” or “space-around” the live test will crash and never be updated.
Have a look and tell me if it is the issue, please.
I’ve tried to set them and my live test crashes when I return to “center” it works well.
If it is the issue, please fix it. Albert.


You see this problem on iOS or only on Android? Before I saw Android crashes when “JustifyContent” = space-evenly. I’ll check everything.

1 Like

I’m using only Android.
Alex. Another question. How to hide a column that has buttons with pics backgrounds.
I’ve tried to set the column to 0% and the buttons are still shown on the screen.

I checked. I have an Android 7.1 emulator with “JustifyContent” to “space-between” or “space-around” that works without problems. And with space-evenly app crashes.

I will now look at the hidden column.

1 Like

The column is scrollable and it has 25 buttons each button height is 200px and they have background images.
If I set the height to 0% and scrollable to false, the buttons are still shown but they freeze. I want to hide the column with its buttons.

My live test crashes when I tried to make spaces among the buttons by setting space-between and it crashed when I returned to center it works well.