Project slowed down and crashing

Help! My project on X has started massively slowing down and behaving strangely and crashing.
everything was suctioning correctly up until 24 hrs ago when it started slowing down massively on live testing.
In some cases the functions work but take 10 to 15 seconds to complete. Sometimes buttons randomly grey out. Sometimes the project takes 20 seconds plus to open sometimes it doesn’t open?
The project is within the Pro size limit at under 35 mb and I have updated the iOS app on my phone.
Would really appreciate some help on this

1 Like

Twll is more or can you share screen shots or a project share link?

Are you using a lot of stored variables? Are you making calls to the internet in those functions? Etc. what does the app do?

1 Like

The project limit is 50 MB so you’re comfortably under that. However, depending on your internet connection, the size might be slowing you down somewhat?

35 MB is actually quite big for a Thunkable Project (yes, I know, the exported apps are generally much bigger, but the projects themselves are much smaller.) are you using a lot of images in your app?

Can you try installing the app on your device @badbrains so that we can narrow this down to Thunkable Live and/or internet connection speed?



I see similar behaviour…

What was working 24h ago suddenly does not work and some things are just behaving much different.

Also loading of my project is much slower.

I know this often happens on weekends, but hay we only at Friday yet…

Here is a screen that have been working for ages, but today gives me a white screen of death

I too noticed this just now. This particular page has been loading quite a bit faster until this test. maybe only a couple seconds. ~5 sec. here it takes ~21 seconds (it took around 14 without the loom recording taking place) but to be fair, this project has around 6000 blocks and this screen in particular has ~3000 blocks. AND i was recording this loom video it just felt really laggy and my browser froze a little while loading the screen too.


I build a sample project here called foo
and it simply loads a page in a webview.
2 lines of code and it gives white screen of death

that project has some kind of error. i created this this morning for another thunker.
try this

my foo project has 2 lines

how can it have error?

I made it public so all can see it I think.

Try without the reload block. Couldn’t you set the url from the design screen?


why I cannot use reload? I need to reload, as user can browse on from that screen and I need to have a fixed starting point upon return to the screen itself.

1 Like

I see. I just wondered if it was causing the issue.

You are right, it does cause the problem. It did not use to be like that, it is not like that in all my webviews, but in this webview the reload causes white screen of death.

I also noticed that calling functions with parameters at startup causes the parameter to be 0 upon reach of function, while not zero before calling the function. That is also a new behaviour…

I think these weekend updates are keeping us busy, and frankly going out of my mind…

@henrikhngj5 We’ve made some changes to speed up the blocks. Unfortunately, this is a case where the blocks are going faster than you would expect.

How it used to work:
It used to be that the url would be set, it would wait a little bit, then call the next block to reload. During that “wait a little bit” the webviewer would load the url, and by the time the reload block was called, the new page had loaded and reload worked fine.

How it works now:
The url is set, but we’ve sped up the blocks so it calls the next block immediately, before the webviewer has loaded the new url. The reload block then is reloading a page with the previous url (which in your case is undefined - an invalid url), which causes it to crash.

Possible solutions:
Obviously, for this example, just don’t use the reload block. If you want the reload block, if you add a wait block, so it’ll “wait a little bit” then it is equivalent to the old behavior.

At Thunkable, we should make it so calling reload doesn’t crash the app if the url is invalid, (especially since our default value is an invalid url :man_facepalming:t5:)


@henrikhngj5 can you provide a simple app where you see the bad behavior?

1 Like

I have the same problem here. I am during this entire afternoon trying to figure out what was happening. It seems that we all have the same issue.
To be more precise, even if I add “wait x seconds”, I cannot load a page which contains webAPI.

Thanks paul!

@IWendling can you provide a small project that demonstrates the problem?

1 Like

I managed to solve. I was just like our friend henrikhngj5, having this white screen of death! Following Paul’s advice, I added a “WAIT” after I declared the variable API_URL.

Thanks for trying to help me.
I do recognize I have no simple (neither organized) project, but if it helps someone else, that’s enough!