Difficulties using the platform

I get lots of problems when using thunkable. I can’t even complete even single project. each day I face a new issue. I complete a project after a lot of effort but it all gets ruined due to errors, problems, and glitches.

What are all your problems?
Maybe we can solve Them?
I’ve seen no problems at all.
No lag, bugs, glitches or failures.

3 Likes

Please don’t say like it is worst
Tell the issue of what you are facing

4 Likes

… this was your 1st post… ive expected to see alot more before these complains… if you faced alot of problems, where is your advice from the comunity first ? cmon…
im new to Thunkable too… and already published an app…
In my opinion Thunkable is great… even Thunkable team, maybe not so much vocal, but they try to solve problems… not to speak about the comunity here…
your post really sounds as a hate with no complementary details, really… :thinking:

4 Likes

Welcome to the community @devtulsiyan3qrf - although your choice of title reminded me of Comic Book Guy from the Simpsons I’ve edited it to bring it into line with our Community Guidelines.

As @lukehoogenboom0i has mentioned already, if you outline some of the issue you’re facing (and provide some context as to what apps you’re building) then this is the best place in the world to get help!

5 Likes

When I give Height Of Any Label fit content (with text entered in it) it get completely collapsed and on entering relative height it it behaves like fill container.

Could you post a screenshot of your editor screen.
I’ve never encoutered these problems your describing.

1 Like


Have you tested on a phone?
Web-preview is not always as accurate as phone preview.

1 Like

The second problem is with the image even with contain picture resize mode the image gets bigger than the whole screen. so I have to use buttons

And my biggest problem is Thunkable
I spent more than 1 month completing it and in the end when my project was completed and it was working fine. but as I click the share link thunkable crashed and I never got my project back.

other problems which I face -
realtime DB does not work
column also has the same problem as a label.
the accelerometer does not work properly.
drag and drop have a lot of issues.

Hmmm.
Don’t have Any of these problems.
Maybe your Just using the components wrong.
accelerometer is not avaible on every device so it may not work.

I can see an error in the console when I open this project - will follow up with the team and get back to you.

For the time being, are you able to make a copy from your /projectPage/?


Can you give a specific example, with blocks for reference.


Can you share a sample project that demonstrates this behaviour please?


How are you trying to use it and what is happening?


Anything in particular here that we can dig into?


Just as a closing note, if you spend a little more time composing your thoughts and questions in the community you will get higher quality answers.

Thank you.

3 Likes

But I use all components correct and a lot of times they do not work. I have to delete and add it again and after doing it lots of time it gets solved.

Have you set the DB URL and DB API key?

saving does not work even with correct URL and API in realtimeDB

yes

Can you please show a link to the editor screen or a copy of it?
Or A screenshot to the blocks would help aswel.

https://x.thunkable.com/copy/6d2ee9a326b7e937439f76f45cc518d0
In This Project, both the label and column in which that label is kept are causing the same problem.

My English is not good because it is my second language, first is Hindi.

Currently I have no projects with this problems. I used That Same Method and Solved This Issue.

No I cant Duplicate that project it shows an error “Error while duplicating project”.

Is that problem is because there is at least 5000 blocks of code. i created this project for an competition.

the accelerometer (Shaking) does not do its task in a single swing I have to do lots of swings to make it work. I tried all sensitivity but nothing helped.

and In drag and drop the interface does not work properly and sometimes the screen turns white and I have to hard refresh it.

I cant add more reply so i am typing here -

My code was reaching 10000 blocks. I removed lots of additional features and used functions to make my code as short as I can. I can’t edit my project because it is not loading.

1 Like

No, it’s a separate issue. As mentioned above, I’m pretty sure this is fixable and if you bear with me I’ll let you know when to try again.

As an aside, 5000 blocks is a decent number of blocks - have you had a look to see if there is any refactoring you can do?

2 Likes