Yandex Translator not responsive

Hi folks, So I’ve been developing a live chat app over the last several months that translates messages automatically between users messages.

I first tried using Yandex, but it didn’t work. Yandex just seemed to be unresponsive for me.
I’ve since tried looking into Google Translate, Watson Translate, and Microsoft Translate REST APIs in the meantime, but am running into bigger hurdles…

I’d love to use Yandex again, since it worked pretty great years ago when I first started tinkering with apps, but here’s the issue I’m running into.
I started by just remixing the basic translate app from the tutorial, right?

I double checked to make sure that selecting the language sets the target language too.

I didn’t change any blocks (and maybe that’s the problem), but I carefully double checked all the steps in the tutorial to make sure nothing big was missing…
Here are the blocks just to make sure…

Then I’ve thought that maybe it was a yandex api issue. I thought, Ok, I’ll go get my own api key from yandex and look over their documentation.
Hmmm… none of yandex seems to be responsive… (here are a couple urls)

Overall, this has been an ongoing problem that I’ve been looking into over the last couple of months, monitoring the yandex website, hoping it was just high traffic at peak hours, or checking the forums for any recent Yandex trouble posts… but I’m getting no luck.

I’m not in a big rush to release my project or anything, but the translations are the last step in the app process holding me up now, and I would love to know if others are having success/problems with yandex, or if anyone has any ideas as to possible solutions!