Why Cloudinary Not Works In Mobile Phone?

As it Shows “Choose A Valid Media Path” on My Android Phone.

You’ll need to provide more details. What do your blocks look like? At what point (after what event/user input) does that message appear? What does the full message look like in a screenshot?

1 Like

This Was What It Was Showing In My Phone.

This Was what it was showing When I Tried other Images.


You have not Replied to a Solution science for a Long time. Please help me with this.

You haven’t answered the questions I asked so I wasn’t able to help you. Maybe someone else can.

I have provided averything above.

Please help.

Can you post a link to your project?


This is your entire project:

The problem is that when you upload an image, you’re trying to get the url from an image that hasn’t been set yet. You mixed up the blocks. They should look like this:

But also, there IS a problem on Android devices. @matt_conroy @ioannis I can confirm that this sample project works on my iPhone 13 Pro to display that url from Cloudinary but on my OnePlus Nord N10 5G (Android), it shows “You need to provide a valid media path.”

@whoocoder Have you tried this with your own Cloudinary account?

1 Like

Yes, I’m using all details like Cloud Name, API Key and API Secret of my Cloudinary Account

Please help.

What do you expect me to do? I don’t work for Thunkable and I already notified their staff members above. If I knew more, I would have posted again.

1 Like

@tatiang @whoocoder There is a known limitation with how the file path is passed in Android devices that causes this issue. I can bring it up again and see if there is a visibility for being able to change it.

The issue itself is this: As the path is passed, it does not start with any of the full path options (think /Users/username/images/my_image.jpg) but merely the last part of the path, my_image.jpg, and that is why the error is returned as “You need to provide a valid media path.” In iOS, the full path is shared automatically.


Please help as fast as you can because this is a major function in my app.

Now It’s working after some help from @ioannis as he told me to attach a photo from the photo Library block.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.