Volume unable to be changed or controlled at all

I’ve seen several posts that talk about the inability to change volume, most of them mention the drag n drop interface, or that it just doesn’t work on the web but it works on the app.

It’s not working for me on anything except for android on the thunkable live app.

I just updated to the latest version of the Thunkable Live iOS app and it’s not working.

It’s setup with both buttons and a slider since that is frequently mentioned in the volume topics.

I have a debug label setup as well.
All I want is the ability to mute and unmute, not just pause and unpause, I want the ability for the song to continue playing while the sound is 0.

@domhnallohanlon has replied to a few of those topics but it seems to no avail.

Here’s the project. Hope this gets worked out.

https://x.thunkable.com/projectPage/6388b442973efe02191cbf63

Is this a known bug? Def stopping me from producing what I’m wanting in an app. I know Dom asks that question frequently

When I preview your project, I’m not having an issue with muting/unmuting. I’m having a problem dragging the slider (it crashes the project) and a problem changing the sound’s volume to an integer (it crashes the project). This is on an iPhone 11. This is in the browser.

An example of blocks that create a crash:

image

Are you able to adjust the slider without it crashing?

Very interesting.

Yes I can change the slider no problem.

Actually, if I don’t change the slider and just tap mute/unmute my debug label only ever reads “volume to”

So I’m assuming it’s null.

Once I touch the slider, then the debug accurately tells me the current value as I slide it.
And then also the mute/unmute correctly displays as volume to 0 (Should be muted) or volume to 100 (Should be loud)

I’m on iPhone 13

So when you mute or unmute it truly mutes the sound for you?

No, when I mute/unmute, it just shows “volume to.” I can play/pause/resume the sound but I if I touch the slider, the project crashes in the browser.

Sorry, I don’t know why I said I was using an iPhone 11 (which I do own…)… testing it now!

Edit: Okay, it works the same as you describe in Thunkable Live on my iPhone. Sorry for the confusion! I can slide the slider and it displays the correct volume value but the actual auditory volume doesn’t change. Setting the volume to any integer value regardless of the slider doesn’t affect the playback volume either.

So it seems as if the set Sound's volume to block doesn’t do anything…?

@conroy Several bugs here…

  1. Assigning the green value block of the slider event to the sound’s volume crashes the project in the browser.
  2. Changing the value of a sound’s volume doesn’t seem to have any effect.
  3. I’m either getting no playback or a strange error when attempting playback of a sound in my own sample project:

And the project link: Thunkable

I find the whole Sound component interface in StP to be confusing. I’m sure you can tell that from my blocks! I never feel confident that a sound will play when I want it to. I do think the DnD sound feature is much easier to use.

But… the Drag and Drop interface doesn’t seem to have any way to change a sound’s volume.

That’s what I’m finding yes. The set volume simply does nothing.

Really wish this was more widely known/reported.

This song specifically is a workout song which times the lyrics to the exercises. So pausing it doesn’t work in my case bc the individual should continue working out.

And if they decide to unmute all the sudden it should stay on track.

I don’t know what to do at this point.

I’d be open to a GitHub post but we’re still waiting on the auto-focus block for text inputs, and one other but can’t remember off the top of my head

Here’s a new bug report I just created:

And oh look! Happy anniversary to my feature request about changing sound volume in DnD:

1 Like

Thanks, @tatiang. I will take a look at these and get something filed.

1 Like

@tatiang @overshield Update here. We have found an issue under the hood with realVolume coming back as undefined. This seems to be the underlying issue for several sound issues and I’m hoping any fix will act to fix all of these issues. I will update again as I hear more.

3 Likes

@tatiang @jared
Thank you

Thank you for this update!

For me it’s kinda the final touch on my app

@overshield @tatiang Could you both check and see if this issue has been fixed on your end? We just sent out a hotfix that should take care of this issue (you may need to do a hard refresh of x.thunkable.com if you already have a window open). Thank you!

Doesn’t seem to be for me so far.

Here’s my test for this

https://x.thunkable.com/projectPage/6388b442973efe02191cbf63

@conroy I can confirm that @overshield’s project doesn’t change volume with the set volume block.

There is also still not a way to change the volume in a DnD project.

1 Like

I actually can’t get a sound to play at all. I suppose that might be something I’m doing wrong in this StP project…?

https://x.thunkable.com/copy/be9d55d97dd9f9dccb415550057e4354

I am able to get sound to work still on mine.
I just hit “tap to start” button and it begins plying the music.

@overshield My apologies on the confusion here, are you saying you are still having trouble getting the sound to play and volume to adjust or it is working for you now?

@tatiang I was able to get the sound to play via your linked project as well. To get it to play again, after stopping, I did have to add in another call. Can you let me know if you are still having troubles getting any sound to to play though?
Screenshot 2023-01-05 at 9.52.28 AM

Getting sound to play was never a problem. I was replying to @tatiang when I said the sound does work for me.

What hasn’t worked and still does not is the ability to mute, or adjust the volume w the slider.