[Solved] My downloaded app won't open

Got it thanks @hugocronyk7. I’m going to move this to it’s own topic so since it’s not about live testing.

That sounds quite unusual - the behaviour sounds like there might be an issue getting data into your app.

Are you using any cloud storage or APIs in your project?

Yes, I have been having the exact same problem.

It affects only iOS (13.5.1) builds for me. Android appears to be fine. It’s very frustrating because it sends you out looking for errors which don’t appear to exist.

Android and ios still crashing for me

I used local storage in a previous version, but in this version, I’m not using neither local nor cloud storage.

I’m using a web API block to call a Google web app.
The web app just reads and writes values from a Google spreadsheet.
All this was working before. It currently works only on Android.

1 Like

@kizzy. For Android, I hard refreshed my browser and downloaded and installed again my app. That worked for me in Android.

So, here is an update.
Today I opened my Android app and it crashed again.
I tried uninstall, download and install again and it did not work this time.

However, if I go to the “Application Info” option on my Android device and click “Delete app data” and then reopen the app, it works this time!!!

Here comes the strangest part: if I close it an reopen it, it crashes again!! Again, if I delete app data, it will work, but the next time I try to open it, it won’t work…

The same works once till you close and reinstall

Iphone 11, Ios 13.5.1
This is my story same for ios: “Delete app” and then reopen the app, it works this time!!!
Here comes the strangest part: if I close it an reopen it, it crashes again!! Again, if I delete app data, it will work, but the next time I try to open it, it won’t work…

1 Like

@doctorsof , at this point, I believe that every app created using Thunkable X, compiled from the last week to now, (including the Thunkable Live App) has the same behaviour. I have just tested a simple app with one screen and one button and the result is the same.

Thanks for the update @doctorsof

At the moment this will let you keep testing. In the meantime we’re working on a fix for the build servers to get solve this issue.

1 Like

Just a quick update here to let you know we’re working on a fix for this.

Let’s confine this thread to issues about built apps not opening. If you are having trouble with Thunkable Live please post here:

I’m having the same problem with the app I built. The first run it works fine but the second time and every time after that I try to open it, it crashes instantly. The issue is on Android and iOS. Not only does my app crash on its own, but the Thunkable Live app crashes too and refuses to open, and I have to reinstall it.

Also there are bugs with Get Row/Update row, etc from Airtable…among other things.

I was trying to built the an app with thunkable but when i install that app in my android phone ,and it kept on crashing it is not opening in mobile just like the thunkable live app, so please any one can help me with this,it will be very useful for my future in thunkable

Hi @vedant.kurulekar12te - this is an on-going issue at the moment.

I’ve move your question to the main topic about this so you’ll be kept up-to-date as we make progress with this.

In the meantime, you can delete your app data to get things working again:


I just wanted to let you know that I attempted to publish my app to the App Store a few days ago and was planning to use Test Flight to test before release however once installed on the phone the first time opened it worked great, after closing the app and re-opening it, it crashed and an alert popped up saying:

{app name} has crashed. Would you like to report this crash to the developer?


1 Like

i published mines in the app sore yesterday and the same thing happen open once i had to pull it from the app store because if people update they would have no app. but mines showed no error


I think mine only showed the error because I was using TestFlight to test my app.

1 Like

Hi, I have got this issue with my app where it keeps crashing on second start. The first time opening is always ok. After crashing if i clear storage on the app info, it will be fine again. Apps not very complex, only two pages, first page is login and second page is the main QR and BLE function.

The problem is i am not sure how to debug this since i cannot see any crash log. If anyone can point me to the right direction, that will be great.

As i read from other posts, i have tried a few suggestion including removing Alert, removing Stored variables and adding ‘when Open’ function to all pages.

I’m almost sure it is problem with my code, because it crashes also on IOS. But i am not sure where to look.

Any help appreciated. Here is the link to my current app