[Solved] Lags in the app solved with tap in the screen?

Hi, in the last app I created, both in the live and installing it, I detected a strange problem: the app is slow and updates the components (images, text, writing on the db, other), only ‘soliciting’ the screen and making tap … . confused!!! in the previous app, much more complex, it doesn’t happen! this both on ios and android. the doubt was that I had something wrong, but the tap on the display really solves the problem … so I ask for help !! I’m sorry for english! Thanks

They all ready know it a lot of people have this problem since the last update ( me to ) @domhnallohanlon @jane :slight_smile:

they told me this

Our understanding right now is that this behavior manifests in apps that 1) get data from any data source (local DB, web api, spreadsheet, realtime DB) and stores that information in an app variable (and possibly also stored and cloud variables).
Initial reports all mentioned using loops, but it seems that apps with loops that eg. created clones of visible components using data from such a source were jus prone to highlighting the issue.
We are talking to people who can provide helpful insight to better understand this behavior.


That seems to be the case, as creators have reported the same behavior in apps that are being Live Tested and apps that have been downloaded.

Hi Dany, i think that the problem is not to get data, because it happen in screen where i have only 2 icons and a listviewer with a simple list. It happen with all the app, without a specific component. I try to change resolution, using variable, object, all, but the problem is solved only with TAP :joy:

the variables are also the problem

I have the same problem as you only on scroll or tap it show the things

In the other project i used tons of variables. Now i learn a bit :joy:, so i’ve only 10… I think that is a general problem, with the behavior of the os when execute any block (the screen too (icon and other) refresh wen you type in the text field.

That’s what they said… they now it and they are surly working on it… I already post it on github also and if you have a look on the community the last 2 days there are a lot who wrote about that

Could you copy the URL of your project from your browser and share it with me?
This URL should begin with x.thunkable.com/projects/

1 Like

Hi Jane,
this is the link:
an idea… may be that the problem begin when i try the component imagerecognizer (or other)? i delete it, but when i add a component, and after I delete it, remains a trace in the code? thank you

I build a testing app. The problem begin when i write on Firebase, not when i read or use other component or variable. In standard mode, the app write in 33sec., with TAP help :slight_smile: in realtime, but now write a additional record scopevariable info… I hope this can help you…

We released a new version of Thunkable ✕ last night which may have solved your problem. Could you please try again?

Note that you might have to do a “hard refresh” (shift-ctrl-R on Windows/Linux shift-cmd-R on Mac) or two in your browser to get the latest version of Thunkable ✕ loaded and then move a block to force a regeneration of your app’s code. Sorry for the problems.



Thank you Mark, now is working very well!