[Solved] "Device is Online" block disables all buttons on screen

As of yesterday, I noticed that all the blocks in the device group do not work!
PS: Android and iOS tests have been performed

test project: https://x.thunkable.com/copy/b54714377d48cb9e95621d8b121a59f8

Hey @Balanced_Kitchen, these look fine to me?

Can you share a screenshot of what it looks like for you please?

Thanks!

Would you test it on a device!
Live test or instal app.

Am I the only one facing this problem?

The problem occurs after updating the live test application. With the old version there is no problem with a live test, but after installing the test application the problem exists.

Does anyone have the same problem?
Why doesn’t anyone react?
However, there are over 15,000 new users. Where are you?

nothing been working 2 days now i was wondering if i am the only one

@Balanced_Kitchen, I’m going to merge your topic in with this one because (hopefully!) they are both part of the same thing.

Android companion v206 is on the Google play store and v205 is on the App Store.

For Android users, can you try out this companion v206?

iOS users, please try v205

Can anyone confirm if that fix the Device is Online issue?

@kizzy @thanos-x @hernandezsilvaericko @actech @Balanced_Kitchen @doctorsof @harri.f

3 Likes

I can confirm that the issue with the Device is Online block is fixed on 206.

1 Like

This did not solve it for me - i’m still experiencing the error.

I also get an error message from my WebAPI.
It returns the error that the target isn’t https - when it is could this be a clue?

Can you share a project link with us @orgelman so we can test this on our end?

Are you using Android or iOS?

Are you live testing or installing?

I’ve tested the livetesting on both ios and android. Is device online works in the Web-tester, but not WebAPI.
I’ve also downloaded the apk to andrid and it crashes right away.

https://x.thunkable.com/projects/5c6d276be7fadd8de2d26b6b/

Ok. it sounds like you’re having an issue with the WebAPI component? If that’s the case can you start (or bump) another topic please?

At the moment, in this topic, we’re trying to make sure that the Device is Online? block is working for everyone.

Is the Device is online? block working ok for you after the latest update @orgelman?

No - the Device is online? block does not work in the live testing-apps or the downloaded apk, but in web testing.

I included the WebAPI as a possible source of error…

Are you using v206 of Thunkable Live @orgelman ?

Yes, the latest version on android.
Both reinstalled it and rebooted the device.

I’ve now removed everything but the if statement - freezes the live-app, but the web-app works as intended.

Does this app work for you?
https://x.thunkable.com/copy/413eacbed6cbfd6232c0da37115d7caa

Yes, i got mine working after i changed Home -> Opens to Home -> Starts

2 Likes

Awesome, glad to hear this is working for you.

Please, if you are experiencing an issue with the web api component, create new new topic in the Community with details/screenshots/a sample app and we’ll take a look as soon as we can.

When using update 206, “Device is online” works for me

1 Like

Awesome thanks everyone, marking this as “solved” so, since we’ve now heard from @actech @orgelman @Deluxe and done some internal testing ourselves.

cc: @kizzy @thanos-x @hernandezsilvaericko @actech @Balanced_Kitchen @doctorsof @harri.f

1 Like