Unable to test my app on device


the application launches in preview mode
on the other hand in live test after the connection screen and the choice of an option I get this message

although it is the same application enough to tear your hair out
i check my blocks again and again and i don’t see what’s wrong

1 Like

Your blocks are crashing the app. It could be a stored variable that isn’t initialized properly or a variable type mismatch or a data source retrieval that doesn’t exist or a number of other things.

1 Like


thanks for your answer

I forgot to specify that on android it gets stuck and that on my ipad it works

but why does it work in preview mode is it less sensitive to block errors?

1 Like

You’ve given so little information that it’s impossible to know.

But I believe the device’s processor speed can affect how the code is interpreted. If you are using blocks affected by timing such as “then do” blocks, this isn’t surprising.

1 Like

I think there must be something going on with the Thunkable servers. I was trying to work on an app yesterday and the app would take a full 10 minutes until the most recent changes would register in the Thunkable Live app. Then my code got corrupted and I had to delete an entire section and recode it before it would work. Now I’m struggling with an issue where two apps have identical code but one runs and another keeps crashing. The app I’m working on uses Firebase so it’s possible that the problem is linked to Google’s servers as well.

Sorry I don’t have any suggestions, just confirming I’m having major issues too!


Adding to the mystery, now the app that isn’t working on my iPad is working on my iPhone.

I’ve spent a lot of time troubleshooting and my problems all have to do with the Airtable component and the Realtime DB component behaving erratically–I run the app once and it works beautifully, then I run it a moment later and it crashes with an error.

1 Like


Can you share a minimal example of apps that demonstrate this issue? No need to share your project, but instead a smaller version that shows the same bug.


It’s hard to diagnose what’s going on without knowing your block combos and the validity of the data (or lack of data) you are evaluating.

AFAIK, there’s no major issues going on atm

I find there’s a lot of lag between making changes and previewing or live testing. I often have to press the Preview or Live Test button 2-3 times to get it to refresh the changes I’ve made in the editor.

I wish I understood that process better. It often makes me doubt my code because I think I’ve fixed something, I preview and it still doesn’t work, and then I preview again and it does and I’m confused about what the cause and effect was.



I also use firebase … :unamused:

Hi Jared,

Yes, here’s a small app which has the same issue as my larger app, except for the fact that it isn’t crashing the small app… in the case of the small app, it just doesn’t work.

The problem seems to be that I can’t nest the Airtable call within the Realtime_DB call. If I remove the Realtime_DB1 call, the Airtable call works perfectly. Once I nest it within the Realtime_DB call, nothing happens after I hit Button1.

Thanks for looking at this!

Agreed. I’ve been having issues all weekend. Sometimes it updates immediately, other times it takes up to a half hour. It makes debugging rather maddening!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.