[SOLVED] Cannot delete components from Thunkable UI

Hello everybody,
I can’t delete a column. Nothing happens.
Thanks.


After…
columm_

So you click Delete and the Column1 component is not removed from the project?

What happens if you do that and then close the browser tab and re-open your project?

Can you share a link to your project so we can try it and let you know if it works for us?

1 Like

Hi tatiang,

  1. Yes.
  2. I tried this and keep the same.
  3. Thunkable

Thanks for Your help.

PS.: This happens too in DnD Mode.

The same thing happens when I open your project and try to delete a column: nothing. The column does not get removed.

I can delete a column from an existing Snap To Place project but I cannot delete a column from a new Snap To Place project that I created such as this one:

https://x.thunkable.com/copy/71bd6d20ea7db1e4ca0dd36973a79b5a

I would recommend filing a bug report:

1 Like

I verified that it happens for any component. The same behaviour.

You’re right!

@domhnallohanlon @jane @wei This seems like a pretty big issue.

Really it is! :frowning_face:

Thanks for reporting! We are looking into it now.

Wei

4 Likes

@ugarovesk5cx @tatiang @wei

Hi! I was facing the same issue yesterday, but not anymore - looks like the bug’s fixed now. :+1: Thanks!

1 Like

@kartik14 @wei
Hi!
Attention: It’s true, but just when I created a new project. What about existing project? :thinking:
Thanks!

@ugarovesk5cx Well, it worked well for me in my existing project.

1 Like

Unfortunately, not for me. :thinking:
Thank You anyway.

1 Like

We are still working on fixing existing projects.

cc @tingc

6 Likes

same. when I open delete or edit some code/component, it reloads the page and I had to do my work again.

this is also coming for existing ones too.

Hi all,

We have a fix released. Can you try again and let us know if this issue is resolved for you?

thanks,
Ting

6 Likes

@tingc
Wow! That’s great. Now it’s ok.
Additionally could You verify the functionality Live Test? It’s working for You?
Thanks.

Hi @ugarovesk5cx

Is it a project that having issue deleting a component and now cannot Live Test?
Do you mind providing the project link so we could take a look? You can share the project link via a direct message if you’d like :slightly_smiling_face:

1 Like

Hi @tingc
After the mentioned bug and even with a new project, I can’t test with Live Test. It simply does not display the project on mobile.

To reproduce this situation, just create a new project, for example, and try to visualize it with Live Test.
PS.: I’m “trying” Thunkable and so I don’t have any special project.

Hi @ugarovesk5cx

We just released a fix. Can you try again and let us know if it is working for you now?

4 Likes