Question about AdMob rewarded video implementation

I have tried many times but the AdMob rewarded video is not showing and my app is skipping that step. I have tried many ways for it to show up, but it is only showing up once in 10 times when it is to show up every time. Can somebody please help? :slight_smile:

Hi @sjalari248eymm ,

What is you ad fill rate?

Is your app published in the App Store or the Play Store?


It is not yet published. I give one video ad, every time the user clicks a certain button.

And I don’t have an ad fill rate.

I think there may be a problem with the AdMob rewarded video component itself. I have even tried to put it in other apps of mine but it doesn’t work whatsoever.

I’ll take a look at this but…

Since your app doesn’t have any users I wouldn’t expect any ads to show.

To use an analog example, if you ran a business, would you take out an ad in a newspaper that did have any readers? Or would you run a commercial on a TV station that didn’t have any viewers?

The exact same logic applies to apps. Display ads are bought by users in order to reach your users, if you don’t have any users then you can’t expect anyone to buy ads in your app.

1 Like

But the AdMob rewarded video ads were showing up until a certain point, and my app was still not published yet at that time.

And it is not ads for my app that I am looking for, it is ads for other apps with the AdMob rewarded video component.

Is this the right code to show a rewarded video ad and then execute some code?

I can’t find your email address anywhere in our AdMob portal - do you have a different account that you use for your monetised apps?

Can you PM me your publisher ID please @sjalari248eymm?

It’s okay, I solved my issue, thanks for your help! :slight_smile:

Can you please post the solution so others with the same question don’t need to create a new topic?

It appears that there is no problem at my end, and all my code and settings are correct, but there is a problem with the AdMob rewarded video itself because every time I try, it is showing an error, I even tried in a different account and I got the same result, is it working for anybody else yet? :man_shrugging:

I assume that this issue will be fixed soon enough. :slightly_smiling_face: