[not Solved] Editing Custom Data Viewer Layouts

Hello! When I go to My Data View Layouts and then click edit, I see that everithing is grayed out and non-editable. How can I start editing the layout?


not suppose to be happen like this. try log out and log in again.

I logged out and logged in as you recommended. No effect. I saw another post, where the user mentioned the grayed-out interface. There was no answer on that particular problem.

all your project have same issue or only this one? try create new one let see if have similar issue.

Just created a new Legacy UI project, created saved a Data Viewer there, and tried changed it through the dashboard. It’s undetable. You can see that my coursor is read.

Did you manage to check the issue, does it work at your side properly?

1 Like

@artem.dzyuba it works properly in my side and I can edit the layout.

Don’t understand what it can be. Still experiencing that issue

I have the same problem.

1 Like

Same problem as well.

1 Like

Seeing the same on our end, unable to edit the modules - as a workaround you could still use your legacy project and save an updated version of your layout and this will be available in your DnD project.

Apologies for the inconvenience, this will keep you going until we fix the module editor.

1 Like

Yes, the only workaround here is to re-save in Legacy and rebind the data in DnD. Thank you.

Hope you will fix it soon, please, notify when you fix it. I 'aso created a bug request on Github yesterday.

1 Like

Can you share a screenshot of what this looks like for you when you click “Edit” in the My Data Viewer Layouts tab @muneer?

1 Like

Will do @domhnallohanlon

Just to let you know this is not the first time this issue is reported. See this

This is a screen shot as you requested. Let me know if you need anything else.

This interface looks different from mine. Mine has no screen in the middle. Maybe that’s because your account was create much earlier than mine, even before DnD was introduced. And this might explain why some accounts have no problem editing modules.

1 Like

Here is the issue I’ve opened in Github with a video about the same isse but nobody seems to have it in charge.

1 Like

Thank you @Giuseppe_Geppo_Catta, @artem.dzyuba
I made more tests related to layouts of the Data Viewer custom tool and was able to reproduce your situation.
@domhnallohanlon You might be interested in these findings
Now I get this screen if I try to edit the layout I created

I found out that this happens if you save the layout from the option if the column in the screen. If, however, you save the layout from the option of the screen directly then you will get a full view just like what I had earlier.

So it seems that they way you save the layout makes the difference.

If you use this you get it working

If You use this, you don’t get the screen at all

Hope this will help find a solution quicker.


Thanks @muneer - this should be very helpful I think!


So basically, if I want to save a column as a custom DVL, then I have to transfer all the column’s contents into an empty screen and save that instead?

1 Like