[not Solved] Editing Custom Data Viewer Layouts

Yes, only if you want to be able to edit it later or until Thunkable provides a fix.

1 Like

Ok perfect, I’ll try as soon as possible.
But so official instructions have to be corrected because they say to save column as layout

2 Likes

I saved a screen instead of just the row with columns. The interface changes, now I see the screen when editing. But still all the proprties are non-editable.

1 Like

I don’t know but let’s ask @domhnallohanlon.

Is this feature (editing layouts) a PRO only feature?

He might shed light on this and we know what is causing it.

Unfortunatelly I can see the screen both if i use column or entire screen to save layout, but editing is still blocked :frowning:

Nope - it (should be) available to all users.

I’ll take a look at this on my test account later today.

I don’t think it should make a difference, but is that screen you’re saving from a private project @artem.dzyuba & @Giuseppe_Geppo_Catta?

1 Like

I happen to be a PRO member and was able to edit the layouts, yesterday the PRO expired and had an idea in my mind to test the issue after being FREE account and now I see it read only and cannot edit.

3 Likes

I’m on Free tarif now, so all the projects are Public

1 Like

I’m a free member, and this wasn’t working since December.

1 Like

@codeswept @muneer @artem.dzyuba @Giuseppe_Geppo_Catta @skulamester @ozel1978 @goutham

A fix has been written for this and is pending release.

thanks for flagging this. When the update goes out I’ll ping you all again so you can test and confirm that it is working.

6 Likes

Cool, thank you so much!

Any update @domhnallohanlon ?

Jane says:

I do still experience that behaviour, I am still unable to edit my Custom Layout.

How about you?
@codeswept @muneer @artem.dzyuba @Giuseppe_Geppo_Catta @ozel1978 @goutham

Same here. I can’t edit my DVLs. However, I’m able to select different items (not able to make changes though), and I find this strange (URL?) icon beside each property name. Wonder what that’s for.

2 Likes

I don’t know who changed thiis for [Solved]. I, as a topicstarter, confirm that the issue still persists and not solved.

I still can’t edit the DVL too, as @codeswept and @skulamester can’t

3 Likes

Hi guys,

Now, it is working for me!

Thanks for the fix.

1 Like

Still not working for me. Maybe I need to apply the fix in a straight way?

No, not working for me. This is what I get:

Unable to add components or edit existing components’ properties.

1 Like

My layouts shows blanc screen on loading. When I refresh the window, I see the error:
Cannot GET /modules/60c205447542a8003a0d2453/openProject/designer