Major web app crash with phone issue

I am not coding or doing anything on Thunkable today. This issue just randomly happened to my published app that has been running for about 4 months now, and this has happened before. Out of nowhere my published web app won’t display. Here is the link: corrupt link.

Last time I had to duplicated my app and published a new web app link. The app does display now, but I can’t log into my app on my phone browser. The app works perfectly on the computer.

So there are two big issues that seem like “thunkable” issues.

  1. Web App link randomly corrupts and I am unable to use the app. (This happens once every 3-6 months)
  2. The realtime DB block is not running like it should. See pic.

I know my blocks and code are right because I have been using this app for months. My company was using it this morning! I even tried an older version I had saved and same result.

I have put a pic with a blue star of what block won’t run correctly. I have deleted and tried replacing but still no luck. I also updated my iPhone software and am on the newest version 15.1. I have tried chrome and safari. My app works great on chrome on windows 10. Having this on the phone is key, but I have had zero luck.

I help this manufacturing company automate work flow with this app. Not having it is very frustrating to say the least. The thunkable team has always fixed my issues. I hope this one goes that same route :grinning:

1 Like

I was able to open your web app. Is this what I should be seeing?

Hi @22rdhallqp - I was also able to open your app, on both my desktop browser and my phone browser. Are there more details you can share about this for when it doesn’t work?

@cassandra & @tatiang. You guys are awesome, that was weird. Since both of you could get on it I figured I should clear my cache browser data. I am able to see my app load like you are on the computer and phone, however…

That did not solve all my issues. Now I can’t login on the phone browser. I can login on a browser on my computer.

I cleared data on my phone browser hoping that would help since it fixed the first problem, but no luck. Any idea what I should try now?

Ex: I am able to change text on a label right before the get block. Once I move the label text inside the get block it doesn’t process it. (this is only on the phone, it works on the computer)

Hey @22rdhallqp :wave:

Are you able to login via other platforms. ie. Can you login when you test the app on your phone.

It definitely loads for me on my phone

@jared thanks for helping! I can get it to load now that I cleared browser data.

I can login on live testing on my phone, live testing on the computer, and with the web app link on my computer.

I can’t login with the web app link On Android or iPhone. I have tried on safari and chrome and deleted all browser data. No luck.

Hope that helps.

1 Like

Would you be willing to provide a test email/password to try to login from our side to help you test further?

Can you provide a dummy account that I can test with?

@jared, @muneer, & @cassandra

The dummy account login is:
Email: 222rdhall@gmail.com
PW: aaaaaa

If you login correctly a message will appear and say “logged in successful”. Please try on a computer browser and phone browser.

When I login as this account on my computer it gives me the “logged in successful” message. When I try logging in on my phone the code runs but seems to stops at the “get” block that I have put a pic on above. It doesn’t take me to where I need to be after that.

1 Like

This is my attempt

Hope this helps

:joy: I’m gonna lose my mind.

@muneer what browser are you using?

1 Like

See the URL bar. It’s Chrome. My phone is an Android phone. Android 11.

May I ask you what option you select when publishing as a Web app?

  • Mobile app
  • Responsive Web app

If you are not sure, can you republish as a Mobile Web app? This should fix your issue.

@muneer, on my iPhone using chrome in a mobile view the app won’t work. If I click “request desktop site” in chrome and log in it works.

I can’t get it to work with safari at all.

Are you viewing in desktop mode, and any thoughts on why that might be?

1 Like

^^shot from an iPhone 11 with iOS 14.7.1 using the chrome browser in “mobile mode”

Strange indeed


Shot in “desktop mode” same phone and browser

Can you verify that you publish the app as a mobile web app?

@jared At least someone else has seen what I have seen. I’m not crazy haha.

@muneer I have posted as a responsive web app.

1 Like

Can you set it as mobile web app?

Just to try and isolate the effect of this option.

1 Like

@muneer same result if I publish as a web app.

1 Like

@22rdhallqp
Does the app work when downloaded or in the companion preview app