Thunkable webapp is not working in Chrome and Safari browsers

Hi, I have created a Web app using Thunkable and published successfully. It’s a very basic app with one web view component. When I load the app in Chrome or Safari browsers it’s not allowing to log in. When I tested it in Thunkable live app, it’s working fine. I am new to Thunkable, any help will be highly appreciate?

The link of the app is :

Error message after login:


I can’t determine anything from the Login screen. You didn’t even mention what you’re using for Login… Firebase?

Post a link to your project or screenshots of the blocks you’re using.

1 Like

Hi Tatiang,
The site is developed using ERPNext framework. I made the Thunkable project public and posted the link below. I am getting “Failed to load resource: the server responded with a status of 404 ()” error in the developer console while login.

The link of the app is :

Try refreshing the cache. It worked for me.

Hi @jonathonschnoor6x4b5,

I tried to refresh cache in both desktop and mobile browser, but the issue still there.

Your link goes to the published webapp. If you want help, post the code, either as an image or a project copy link.

This is from my desktop

Check your browser’s settings if the issue persists.

I think his error is after he clicks login.

1 Like

Then he/she needs to supply us with credentials that we can rely on. Testing assumptions on assumptions becomes so hard.

Again, anything out of the scope of Thunkable is hard to test. The “Login” process is something to do with the webpage. If the codes in the webpage is assuming some session codes or other parameters to be available then he/she can rectify.

Yeah, The issue occurs after login. I am afraid that I can share the full source code of the project. I can set up a sample project and share the project link.

Understood. Building a minimal sample project with the same issue can be a great way to debug the issue, and will make it MUCH easier to help you with it. We can’t do anything with “the server returns 404”.

Hi @muneer,
I can give you a login credentials for the project, just to recreate the issue. I can only notice this issue when I login in Webapp, it’s working fine with Thunkable live app.

1 Like

Yeah, I can understand that. I will setup a sample project and share you the details soon.

It might be a problem with http vs https (webapp is cranky about that), or a CORS restriction…

I was wondering about that too.
With Http the site is not loading at all, If CORS restriction then it may reflect in the Thunkable live app too.
There was issues initially when I loading site url in Webapp, we resolve it by nginx configuration.

1 Like
1 Like

If you used nginx then you have CORS issues and you are just trying to “fool” the system which might not work with all options/actions in the webpage.

Yeah, So the Web API call is blocked due to the CORS issue, it there any workaround for this.

1 Like

Hi @catsarisky, Thanks for sharing this article. I have tested this with Firefox browser, it’s working fine even in different operating systems.
I mean that, if I load the Wep App url in Firefox browser it works in IOS, Andriod and windows

1 Like

Unfortunately, that doesn’t mean it’ll work in a web viewer component inside webapp.

1 Like