Issues with updating Thunkable App Store apps

Hi all,

I’m currently having issues in submitting a new version (update) to App Store Connect from Thunkable; have the team looked into this? The main issue is with actually submitting a new build version - Apple says to “submit your builds using Xcode or Application Loader”, and it seems that Thunkable doesn’t support this - thus, someone cannot release app updates through Thunkable. Does anyone have any solutions?


Hi @AyushS, thanks for flagging this - let me raise this with the dev team and I’ll get back to you as soon as possible.

Thanks for your patience,


Hi Domhnall,


A post was split to a new message: Updating iOS App

I have the same problem, it looks like it is not sending the app to an apple connect.
Any solution ?

Hi @Geneilson_Leonardo, welcome to the Thunkable community! :wave:

Sorry to hear you are having issues sending your app to the App Store. Can you clarify a couple of things for me first please?

  1. Is this the first time this app is being published or are you updating an existing app?
  2. Did you receive any email from Thunkable about the status of your app?

First time.
Yes, I received this email:

Congrats on getting one step closer to publishing Appino!

  • The Thunkable Beaver

Your app has been sent successfully to App Store Connect!

You should receive an email from Apple with further instructions on how to submit your app for review to the App Store.
Submitting your app for review
If this is your first time publishing to the App Store, please see our recommendations on how to best navigate this process.

1 Like

I also have this problem - how to " Submit your builds using Xcode or Application Loader."

Something like this happens to me, too. But my application is still being updated. Here’s the message they sent me: Dear Developer,

We identified one or more issues with a recent delivery for your app, “Talk to me- Talk to your phone”. Your delivery was successful, but you may wish to correct the following issues in your next delivery:

Missing Push Notification Entitlement - Your app appears to register with the Apple Push Notification service, but the app signature’s entitlements do not include the “aps-environment” entitlement. If your app uses the Apple Push Notification service, make sure your App ID is enabled for Push Notification in the Provisioning Portal, and resubmit after signing your app with a Distribution provisioning profile that includes the “aps-environment” entitlement. Xcode does not automatically copy the aps-environment entitlement from provisioning profiles at build time. This behavior is intentional. To use this entitlement, either enable Push Notifications in the project editor’s Capabilities pane, or manually add the entitlement to your entitlements file. For more information, see

After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to App Store Connect.

Best regards,

The App Store Team

does your app use notifications?

I do not use notifications in my app

Good news - my app is on the Apple store! Not 100 percent sure how, but one day the build was there, and I selected it.

Now - how do I get a build there for an update to the app?

1 Like

Hi Lin,

You should send your app to App Store Again using Thunkable with a new Build and Version number. It should then soon (after about an hour) appear in App Store Connect where you can choose it as a build for a new app version (or update).


1 Like

Also, now how to I add another app? Can I use the same certificate?

When I am trying to upload an app to the Apple store, you send me an email. Do I have to click the download onto an IPAD or apple computer? After I down load it, do I have to do anything else?

Congrats @Lin

Not sure if you’ve posted here already, but #SuccessfullyTHUNKd is a way to promote your app for free to other community members:

I´m trying to update my app but not happens.

I do not receive any email (from Thunkable nor Apple). No error message.

The compilations list at Apple Dev. Page does not show the version I´m trying to send.

The first publish worked fine and easy. This update I´m not getting somethin right.

I solved the problems changing the app password on Apple Store and re-uploading the app.
All worked fine. Thanks!

Adding on to this thread:
Initial version of my app works well in live test. I set it up in the App Store and went through the process and it works well in Test Flight, except the maps do not show up in the app. Any ideas? I am using Google Maps.