Oops! Your app did not publish

I’ve been having problems pushing an update for my app to the App Store from Thunkable for two days now. I had an update rejected by the App Store review team on late Friday and since then I haven’t been able to send an updated version to the App Store from Thunkable.

So, I don’t mean that I’d be having trouble with the App Store review, it’s more basic than this: I simply can’t send a new build to the App Store in the first place. I just keep getting “Oops! Your app … did not publish” message from Thunkable when I try to send a new build (I get this e-mail a few minutes after submitting the app from Thunkable).

I’ve basically tried everything, but cannot get around this issue.

Are others experiencing this? Or if not, do you have any ideas for how to fix this? It can’t be things like icon size (which has been the issue in the past) as I haven’t basically changed anything since the last time I was able to send an update to the App Store Connect (which was on early Friday).

Hello, the same thing happened to me, after trying publish to iOS, I got an email saying that something was wrong with the iOS build/publish. And recently I read that someone else had the same problem so I think there is an issue with thunkable when trying to publish on iOS. @domhnallohanlon

What was the error message you received?

The message I got was simply this:

Something went wrong when we tried to publish your app.

Here are the details:

There is something wrong with the iOS build/publish. Please contact customer service with the reference ID.

///

I contacted the support but if this is a more general problem, it would certainly need to be fixed somewhat soon. Hopefully it will be resolved.

Ping @wei @jared @domhnallohanlon etc.

If you haven’t already, throw the reference is from the email into a chat on intercom or here in a DM and I’ll review in a couple hours!

1 Like

Thank you! Will do so in a sec.

DM’d with the error log :slight_smile:

1 Like

Thank you Jared, it helped me to correct the issue.

So basically, the error was that I should submit a build with a higher version number than my previous attempt. My background for the situation was that I had submitted version 10 of my app and then this was reviewed by Apple but rejected, so naturally I tried to submit a new build for the version 10. But for some odd reason version 10 was now used, and I had to change the version number to a higher one, i.e. version 11, on both ends (at the App Store as well as on Thunkable) to get it working. Just a tip to you others who are struggling with the same issue (probably).

My guess is that this boils down to the fact that Apple recently changed its review system to be more partial (i.e. if something is rejected, you don’t need to submit the whole package again, just the critical parts). So, I’m assuming that for me the build was partially accepted and even though I removed the whole thing from the review, the App Store Connect still assumed that version 10 was accepted (as if it was published on the App Store), and naturally then blocked me from submitting new builds for the version 10 anymore. Or maybe I’m wrong. But anyway, changing the version number to a higher one, and skipping the version 10 altogether, helped me to resolve the issue.

So, big thanks to @jared for a quick help! And hope this helps others here too.

Edit. I’m also using TestFlight alongside the official release, and I had the build reviewed and accepted there, which might be another reason that this version (10) was “used”. Or maybe not, but just something that came to my mind.