Images not showing up on Android devices

I’m curious if there are specs for image files that work/don’t work on Android phones?

I published an app on the App Store and it works great on iOS devices. But my friend installed the .apk and all of the images are missing. The screen background picture is white/blank and the button pictures are solid grey instead of faded.

Does it have something to do with transparencies? I’m using a bunch of semi-opaque images exported from Illustrator.

Does it matter if I use .pngs or .jpgs?

I saw an old thread about this from three years ago and it also mentioned the need for absolute value sizes for pictures on Android. I’m using relative sizes (e.g. 10%) for most components. I suppose I could switch to absolute (pixel) values but I’d rather not.

Thanks for any insights and advice!

1 Like

If you can give me the link to your APK, I’ll install and test and give you a feedback

Thanks, I might do that but I have a co-worker who’s donating his older Android device to me this week so I think I’ll give that a shot first.

1 Like

My kids’ team has an app with 18 images. Everything looks OK in Thunkable Live on iOS or Live on Android and the web preview/publish to web (well, except some issues with image layout that are still unresolved), but when I built an APK for android, three images are missing. They’re the last three on the list in the design view - everything else is OK. I rebuilt the APK (twice), but the problem is the same. Help??

Project link (but set to private), in case Dom or Jane wants to have a look? Thunkable

This would have been my first recommendation :joy:

There’s a 50mb limit, but this doesn’t sound like that. Will take a look now!

Thanks, Dom!

I wonder if it /is/ a size limit. The APK I downloaded weighs in at 48MB…

No, this about normal I think - it’s the project assets that have to be under 50 MB so you’d have a built apk in the region of 80 or 90 MB

I just downloaded the app there and can see some of the images are missing alright.

Going to take a loot at file names and file types first!

Many thanks, @domhnallohanlon

yes actually theres no size limit but i hope ur app doesn’t hang… till now never happened with me
yes and @domhnallohanlon is right… theres rare chnces of such heavy image files tho

I changed .JPG to .jpg and managed to get that image to display

Screenshot 2021-04-03 at 15.28.12

Screenshot 2021-04-03 at 15.28.04

Ah. Interesting. I’ll do another Android build and see if that’s got it fixed. The other two I was having trouble with I don’t think I have weird caps (toetouches.gif and exquest.png) currently, unless you changed them?

Nope. I’m still missing all of the last three images (touchtoes, gnome, and exquest) when I run it from the Android.apk

Can u please tell us which size u use for this 3 images

i was have this problem when i was use the fill contaner for the Width

but when i use Absolute Size its working
i dont know if this will help u :sweat_smile:

@domhnallohanlon , I just opened up the .apk file, and I see the problem. The images are there, but they’re under their original names, NOT the renamed names shown in Thunkable. Is that possibly the problem? Those look to be the three images that were renamed.

I’m going to try deleting them and uploading them with their final names and see if that helps…

Yep. Renaming images in non-drag-and-drop Thunkable X-platform breaks the Android .apk.

Solution (workaround): Delete previously renamed images and upload with desired names already set.

Hi there,

I was developing my app whole time on iOS and the day came, I installed it on Android to test it there, but I have a huge problem, the images don’t show on the Android device.

The live app looks great:

But if I install:

This thing affects all of my screens.

Things I have tried:

  • Rebuild the app
  • Reinstall the app
  • Clear cache
  • Give all of the permissions
  • Restart the phone
1 Like

On BlueStacks I get the same result, so it isn’t a phone-specific issue:

Does anyone have any idea?

1 Like

These threads might shed some light on this issue:

(especially the last post)

(especially the first post)

1 Like

Thanks for the answer!

Well, I think it is the case at my side as well, but I have 100+ assets so deleting and reuploading them wouldn’t be so funny.

I wonder when the fix comes. Until then I will consider not to publish the app into the PlayStore.

Anyway, I can’t see the bug reported in GitHub, can you?

Update: Now we have one.

1 Like

Hi Cathy,

I’m glad you were able to identify the cause of this behavior! Do you happen to know if the same thing happens on iOS?

I will replicate and report this behavior.

Thanks,
Jane

1 Like

Hi @Jane,

On iOS it works, it only effects the Android .apk file.

1 Like