I have trouble almost 2weeks about publish in Appstore


#1

I have trouble almost 2weeks about publish in Appstore.

I tried so many time, but now I can’t get e-mail which telling it was successful or not.
I followed thunkable docs, but the results are always failed.
Actually I got e-mail from apple only two times(I tried 10 or more time.), included this message.

And I can’t understand What cause the problem.
So this is what I did.

  1. I download csr file from thunkable and upload that.

  2. I haver only 1 certificate and type is distribution.
    I checked ‘app store and adhoc’

  3. I created wild card ID(wingway) so app ID is wingway.w


  4. prov file is also active with my certificate.

  5. In appstore, the Bundle ID is match with I created in apple developer.
    Also I created App specific password.

  6. I upload all of icon(1024x1024,192x192), app information, screenshots. And my app didn’t include Push Notifications.

I read and read docs, tried and tried to fix the probelm. But I can’t find the defect.
So I need specific help… what should I fix?


#2

Hi @c853a2a5f276a158117e,

Sorry to hear you are having issues with publishing your app to the app store for so long. I had a look through our chat support too and can’t seem to find any messages from you in relation to this - is this the first time you have reported this issue?


If you are creating a wildcard id, it should be com.wingway.*

We have a more detailed walk through on our YouTube channel


#3

Thanks Domhnall.
I created new Wild card Id in that form and I send it.
I wish It works!


#4

Well This is sad news.

It said
Verify your dundle identifier ‘com.allineedinterview.*’ is correct.

But I already created Wild card Id in that form.(com.wingway1.*)
However, In App store connect, create with Wild card Id needs suffix.

So I added suffix ‘w’ and the Id changed to ‘com.wingway1.w’
And they said The Bundle Id is ‘com.wingway.w’
so I use the Bundle Id com.wingway.w

The new Wildcard Id was ‘com.allineedinterview.*’
But after I added suffix(wing), It changed to ‘com.allineedinterview.wing’
So do I need to change all of the app Id into ‘com.allineedinterview.wing’ ?


If I need to, It can’t be the solution.
Because I already tried that.(Changing all of WildCard Id ‘com.wingway1.*’ into Wildcard Id+suffix ‘wingway1.w’


#5

You’ll also need to set the same bundle ID in your app settings.


#6

Yes, I knew that I need to set the same bundle ID in my app settings.

So this is what I wondering about now.

  1. I created Wildcard Id (com.allineedinterview.) so I set app setting com.allineedinterview.

  2. In the app store connect, I tried to set bundle Id in ‘com.allineedinterview.*’.
    But the error comes out that I need suffix.

  3. I texted suffix ‘wing’, so the App store connect said bundle ID is changed into ‘com.allineedinterview.wing’

  4. And your answer is that I need to change all of the App Id “com.allineedinterview.*” into “com.allineedinterview.wing” in all steps(mobile prov, app setting…)
    Is it right?


#7

Hi Domhnall. Thanks for reply.

I set same bundle Id and I got message from thunkable.

But I got e-mail from apple again.

I created distribution cer, use same bundle Id.
I exactly followed thunkable docs.
also I use thunkable csr file.
What is the problem??