Easy issue with Airtable "cannot read property 'select' or undefined"

Hello,

i’m facing this unusual problem with Airtable.

WhatsApp Image 2023-12-19 at 17.38.41

I can assure that the table is called “Offerte” and that the rowNum 1 is filled:

WhatsApp Image 2023-12-19 at 17.39.56 (1)

Nonetheless it shows me this error:
airtable cannot read property ‘select’ or undefined

Maybe it can’t read field generated by formulas?
Im still trying to wrap my head around the new airtable OAuth, but i’m sure i connected it well as some of the data viewers in this app are showing this table’s fields

Am I missing something?

EDIT:

I tried with a Text field instead of Formula but i’m still getting the same error.

EDIT2

I have added the Airtable’s token ID on the blank space where i used to put the Airtable APIkeys (invisible component settings) and tried to get cells from another table instead of “Offerte” but from the same base.

Now both the value and the error show me “undefined”

Tried again this morning but with the same result, is it a known bug or am i definitly doing something bad?

Hello, someone faced the same issue before?

Might it be a bug?

Hello @maurizio.polverini89
The blocks you have used connect to Airtable through the API key. Unfortunately, Airtable is deprecating the use of API keys.

Could you please use the blocks that connect to AirTable with OAuth?

Here you can find them: