Create row block not working well from yesterday

Hi, I am having problems with data source. Yesterday I noticed the ‘create row’ block is not working well. I used a ‘create row’ block inside a ‘count with’ block but the ‘create row’ block executes only 1 time. Besides, the blocks I put in the ‘do’ space do not execute. Any suggestions ? It seems that after and inside the ‘create row’ block nothing else execute

I’m wondering if you’re trying to create rows too quickly. If you have a “count with” block without any delays, it’s probably way too fast. Can you post a screenshot of those blocks?

can you show us your blocks? It would make troubhleshooting easier.

2 days ago it was working fine. Now it stopped working, also the blocks that are in the do section in the ‘create row’ block are never executed, not even once. Here the blocks from a simpler project I did to test
scCodeTry1

Ivan_Gonzalez, I have had a TON of issues similar to the one you are describing. My experience has been that trying to insert into a data source in a loop causes crashes. Period. There is an asyncronicity issue with the Create row block (as tatiang indicated).

Sometimes it will work. Sometimes it will work mulitple times. But if you loop enough times it will fail.

I’ve tried adding wait loops inside the Create Row block, which helps, but does not resolve the issue.

Because of those issues, I went to Firebase Realtime Database. Of course, you loose the data viewer, but at least you can add/update/delete data reliably.

I’ve also posted in the discussion group an number of solutions including a JSON bound list, a JSON driven scrolling row, combining JSON data with Local DBs, as well as how to extract data in bulk from spreadsheets and load it into screens and JSON hierarchies.

Best of luck and happy thunking!

1 Like

I tested the ‘create row’ block without doing any iteration, just run the ‘create row’ block once and the row was created but the blocks within the ‘do’ section were not executed, I think is no a matter of asyncronicity or speed.
I remember that a few weeks ago that happened, that is, the blocks that I added inside or after the ‘delete row’ block were not executed. Then they updated to a new ‘delete all rows’ block and now it does work fine and now the blocks that I add inside the ‘create row’ block don’t execute. Here the blocks of the new test I did

scCodeTry2

Yikes! Sounds like you should report a bug on GitHub https://github.com/thunkable/thunkable-issues/issues/new/choose

What data source are you using? Is it google sheets? If so, I’ve encounter a number of really unpreditable errors, especially when trying to add or delete rows. When I encounter such errors, I’ve found the following strategies helpful:

  1. Delete empty rows after your data (yes, potentially thousands of rows)
  2. Delete the first and last row

These are all crummy solutions,but sometimes you need to “jiggle the handle”

Have you guys tried recursion instead of a loop?

I also tried recursion and it did not work, all blocks that are in ‘do’ section and after ‘create row’ block are not executed

I am having the EXACT same issue. My code was working perfectly up until about 2 days ago. I was searching through community to see if anyone else had the same error.

@Ivan_Gonzalez

I’m having a similar issue. I tried the following blocks:

Function
…Set status label text to “A”
…Create Row
____do Set status label text to “B”
…Set status label text to “C”

If I run that code, I see “A” but nothing else. So it doesn’t run the blocks in the “do” section of the Create Row block or any blocks after the Create Row block.

I tried adding a Wait 0.3 seconds block after the Create Row block but it doesn’t change anything.

1 Like

Here’s a small demo. If I click the Add Row button, I’d expect to see “B” or “C” in the status label. But I only see “A”.

See bug report here: https://github.com/thunkable/thunkable-issues/issues/699

1 Like

Hola, estoy teniendo exactamente el mismo problema!!! hace 2 días funcionaba y ahora dejó de funcionar!!!

Hi there,

Same issue here - it seems the system is not able to get the “do” section and it seems, also, that the loop ends after the first item has been added.

1 Like

¡Ay! Parece que todos deberíamos informar del error en GitHub así lo solucionan lo antes posible!!! https://github.com/thunkable/thunkable-issues/issues/new/choose

It’s broken for me too: https://x.thunkable.com/copy/d374e71276f69fc84661243410cc838d

Adding to the discussion

tatiang , i changed you application and it is work

i used list2 instead of datasource for list values in List_Viewer1

you see change values in the datasource by List_Viewer1

@bilastois Which problem were you attempting to fix? The demo I had posted shows that the “do” section of the create row block doesn’t work. But you have nothing in your “do” section…