[Solved] 'Create row' block problem

help please list view stopped working
Does anyone have a solution? Please, it’s urgent, I need it

You’ll need to post some details if you want anyone on the forum to be able to help you. What’s it doing? What should it do? What blocks do you have?

You have posted about this a lot of times, and @tatiang even closed your last topic so you could keep it to one topic. Please do not create multiple topics for the same issue.

1 Like

Hello thanks for answering, I made several topics because it is important and I need it, sorry for the inconvenience
the problem is that data viewer does not work
emulating on the phone if it works, but when I compile it it doesn’t work
Capturfea
Here is an example of how I create the list
all my apps i made worked but now none work.
the create in row block does not work, it only works emulating but when I compile and install it it stops working

Well, it certainly makes it harder to follow the discussion, as I just responded to you on your other thread. Here’s what I said:

I’m responding here since this looks like the original post and the only one with useful information about the problem. Posting 3x in 13 hours about the same problem is not appropriate. Many of the forum regulars were ASLEEP 13 hours ago. If you aren’t getting help after a couple days, you can always “bump” the same thread by posting in it again, but new posts just make a mess of the forum.

Please tell us more about the problem. What do you mean by “doesn’t work” - does the listviewer not get data? Does it get the wrong data? Does the app crash? Where are you actually using listviewer? That’s not obvious in this code, which seems to be about copying data from one spreadsheet to another.

I see a bunch of purple blocks. Which database(s) are you using? (Airtable/Google Sheets/Local?)

You said it works in the emulator - you mean Thunkable Live? But not as a downloaded APK file? What version of Android are you running?

Are you using list viewer, or data viewer list? Those are not the same thing.

2 Likes

again and again same problem with asyncronous datas :slight_smile:
learned from @muneer (thank you again for that), and here the solution for your issue


hope it helps… just adapt at your variables… was just made for you :slight_smile:

1 Like

hello thank you very much for answering
see this is the method I use to create the list
Captusdsddra
it always worked perfectly for me
here you have a link to the project, if you emulate it it works perfectly, but when I generate the apk and install it it stops working
https://x.thunkable.com/copy/357d464820a00e505b7396775a13e881

here is a video of when the app is compiled it stops working


and to finish here is the emulated application that works perfectly

1 Like

You are using Airtable and copying from it to a Local table to show in DVL (Data Viewer List) and not a list viewer.

Testing the project requires access to the Airtable table which means:

  • Either exposing the API key and Base ID of your Airtable
  • Or share the table so I can link it to the project using my Airtable API key.

The code has no kind of error trapping so basically you do not know if the blocks have worked the way they are supposed to or there is an issue.

1 Like

Hello muneer, I’m glad you answered me since you were the one who taught me how to use the list view
here you have access to the airtable base

I have like 5 or 7 applications made this way and never had problems, but now something is happening, this method is not working.

1 Like

It works for me on Thunkable app on the phone

of course in thunkable app it works perfectly, but when compiled into apk it doesn’t work


and also in the web emulator it doesn’t work either

1 Like

There’s a problem with the create row block in web apps / web preview. I’m going to test my demo project in a downloaded app as well.

Yep. Create row is bugged on built apps also, although not in Thunkable Live. Android (7) and iOS (14) both.

Correction: Create row will happily create rows. What won’t happen is any code placed in the “do” area OR after the create row block. I can think of some ideas for a workaround, but they’re not pretty, and unless I /had/ to have working code TODAY, I wouldn’t try them, in hopes that everything will be working again soon.

4 Likes

To keep everyone in the loop, here is the post @catsarisky was referring too. I feel many of these issues will be resolved at the same time as I think many are linked in the background. So if anyone gets better test results, please let us know!

1 Like

Update: I just updated Thunkable Live to 276-1 and now Live is also broken. 271 worked, 276 does not.

The issue affects both the delete all rows and create row blocks, on all platforms.

2 Likes

@jane @domhnallohanlon @Thunkable_Staff

They are key features in our apps, please fix them ASAP, thanks!

2 Likes

Hi @catsarisky,

Thanks for this clear description of the issue at hand.

Let me know if this is correct:
For the Data Sources blocks Create Row and Delete All Rows, the blocks inside the ‘then do’ section of these blocks will not execute. This behavior is not seen with other Data Source blocks.

Is this correct?

3 Likes

Hi @jane.

Both the blocks within the “then do” AND the blocks that come AFTER the data source blocks don’t execute.

I’ve got sample projects demonstrating the issue posted with the Github bugs. In the example below, NEITHER label1 nor label2 gets changed. (However, the row does get created.)

I have not comprehensively tested other data source blocks. But yeah, let me test and add some additional data (all are iOS, Live version 276-1):

  • Get row object and get value seem to be fine.
  • Update value updates the value but doesn’t execute code that comes after it. BROKEN.
  • Can’t test delete all rows with anything other than local database, so haven’t tested it.
  • List of values is fine as is number of rows
6 Likes

Let me comment on Delete All Rows which works only the first time the app runs and all subsequent trials fail.

3 Likes

Hey everyone, I have an update. The create block row is running correctly for me on a web app, so I would give the create and clear blocks a try. I am waiting to test it on native apps. It is not working on Live yet with app V278.

UPDATE
At this point, iOS Native, Android Native, and Thunkable Live are still not working on my end.

4 Likes

if everything works perfectly as before :clap: :clap: :clap: :clap: :grinning: :grinning: :grinning: :smiley: :smiley: :star_struck: