Create Row block - is this how it is used?

I am wondering if I am using this block correctly, as I have a google sheet set up but nothing is posting to it. I can’t find enough details in the Documents, and I haven’t found anything in the forum to help. I’ve tried a bunch of ways and this seems to be right but I am not getting the expected result.

Thanks for looking :slight_smile:

It’s not a good idea to use a navigate block before a block you care about. I don’t think blocks generally run in the background… you have to be on that screen for the create row to complete its functionality. Switch the order of those blocks but also – at least for testing – add a Wait 5 seconds block between the create row and navigate blocks. Make sure that it adds a new row to your data source. Then reduce/remove the Wait time and see where the threshold is.

Better yet, forget the Wait block and just put the navigate block in the “do” section of the create row block.

I tried putting the navigate block in the do section - when I click the add entry button, it clicks but nothing else happens and it stays on the same screen.

It’s unlikely the create row block is broken. It’s more likely that one of your column values is invalid.

Try using all text blocks to test that theory.

1 Like

Ok, I replaced all the values with text blocks and now it runs through the way it should, but does not make a new row / entry on the spreadsheet.

I tried replacing the values one at a time to see what happens, and it runs. Sometimes, it doesn’t go to the next page when I use the text input’s text blocks, but other times it runs fine. As the text is the info I need in the row, I’m not sure how to modify this.

Screenshot attached to show subbing a block for blank text blocks.

Are you using a local database, Google Sheet, or Airtable?

Can you remove the navigate block and add a block in the “do” section that set’s a label’s text to something like “created row”? And add a block below the create row block (not in the “do” section) that set’s a label’s text to something like “done”?

When you click the button, you should see “done” and then “created row” (because the blocks fire instantly but the create row block takes a little while to complete its tasks.

What do you see when you do that?

1 Like

You should know:

  1. Empty text will not create a row unless there is a text in one of the columns.
  2. It will navigate to the screen but you need to wait few moment (It depends on the quantity of data in the sheet).
  3. Goog internet speed up the process.
  4. On build app, it will be a bit faster than the Live test.

Let’s see what your issues are.

@tatiang I removed the blocks changing the background colour in the lists, as you mentioned that is a known error (now I know too lol), and added the blocks you suggested.

It runs through, and all fields are showing up in the Google sheet that is attached. I am cautiously optimistic that this will continue working. My values Favourite and CBD blocks obviously are not right, as they are not switching to Yes when selected, and is leaving a No in the spreadsheet.

As the blocks added (create row, done) are not needed now, I replaced the “do” with a delay. It is still working and making rows.

When I tried the app out on mobile live, it crashed with a critical error when I tapped the Strain button (again).

EDIT: I changed my Favourite and CBD blocks and they are now showing in the spreadsheet correctly. So still need to figure out why it crashes. No clue :frowning:

@Hayder Thanks for the tips :slight_smile:
When I added my rows in, there was data to post to the spreadsheet, so a row was created. The time for the actions to complete is a non-issue right now - when it works, it works fine, lol. I always allow a bit extra time before I start thinking it’s not working.

I have trouble with the Live test. The app always crashes when I tap the first button, and I’ve revampled the blocks and removed some - the app works on web, crashes on mobile.

Have you checked Thunkable live app update on store?

I have the most current Thunkable, but I reinstalled from the play store to be sure. My app still crashes when I tap the first button.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.