Cannot send my ios app to the app store

I’ve been trying for days days to send my ios app to app store connect but it keeps telling me there is an error I contacted the support email twice but there was no real help, can someone please help me out here?

Here’s the error message:

Command failed: cd /thunkableCompanionTemp/thunkableCompanion_6fe2ae37-3d23-4f95-afe7-1f9cbdd8cdcf/ios && bundle exec fastlane release app_identifier:‘com.abdirahiim1000.appname’ app_name:“AppName” team_id:‘TEAMID’ two_factor:‘true’ build_number:‘20202993’ version_number:‘1’ xcode_project_path:'/Documents/thunkable-for-ios/thunkableCompanionTemp/thunkableCompanion_6fe2ae37-3d23-4f95-afe7-1f9cbdd8cdcf/ios/thunkablecompanion.xcodeproj’ has_push_notification_component:‘false’ profile_uuid:‘e14e62be-58dd-4bd7-bde1-f8a774c22558’ profile_name:‘MyApps’ [31m [!] Error building the application - see the log above [0m

Hi @abdirahiim

Just to continue on from our earlier email conversation.

We’ve recently updated our iOS build system. We’re in the process of deploying this update to all users.

If you hold on for (at most!) another 24 hours this fix should be live.


Thanks for the response but you said to use a small build number instead of the build date, but I don’t think I can do that, I think it’s something done by the thunkable system.

1 Like

Yep, that new build number is part of our updated system. I’m just after learning about it a couple of hours ago.

I appreciate it’s frustrating right now, but just wanted to follow-up to let you know that this is the highest priority for us right now.

Thanks again for your patience,


Thanks, I appreciate the explanation, I’ll wait for about 24 hours for the update until it’s released.

I waited 24 hours but still got the same error message

Thanks @abdirahiim for following up with us.

The update is being reviewed at the moment and we’re expecting it to be released later today.

When it’s live I’ll update this post.

Thanks again for staying on top of this!

1 Like

@abdirahiim the latest update is now live.

I’d recommend doing a hard refresh to make sure your on the current version.

Let us know whether or not that works for you!

About the build number, I can’t see a setting to change it

That should all be done automagically in the background so you so don’t have to worry about that.


Still getting the same error

@abdirahiim - just to help us triage this issue can you try installing your app on your own iOS device first?

I just want to confirm that our build update is working for you.

I suspect that the issue might be related to something else.


I can install it on my phone but I can’t send the app to app store connect when ever I try I get the previous error

I was getting a similar message last time I tried to publish an app. What I ended up doing was signing in to App Store connect with my username and password to make sure I was putting it in the right way and found out that I was not actually entering my username and password the right way. I had also entered my team ID wrong so I was getting multiple errors and the fences were to lower my bill number to the 900s, currently my bill number is 931. And then I also just re-checked team ID app password and my user name and password and verify that all of my information was correct. After that the error didn’t occur anymore

1 Like

Thanks @jgibb20189 for the response, I checked my username, password and teamid they are all correct but I’m still getting the error, but you got your build number down to the 900s, how did you do that?

I got a little carried away :teddy_bear:

But that’s the version number, how did you change the build number, mine is the current date