App icon does no longer show up during app start (iOS only)

Hi all, I have changed the app icon to a different picture, and found that now during app loading the icon shows up only for a fragment of a second. The app starts, but normally you can see the app icon during the whole startup process. I changed the app icon back to the first one (which worked before), but this behaviour stays the same.

It happens with a downloaded iOS app, and on android everything works as expected.

And I followed the rules for icons: 192*192px, PNG, no weird characters like “&” in the filename.

iOS 13.6 / iPhone 6S.

Thanks @Michael_Rogulla - that sounds interesting alright.

Can you try a with a blank project, just so we have something to compare it to, please?

Just create a new project, change the icon and let us know whether the behaviour is the same or not.

Thanks.

Hi @domhnallohanlon, I tried to build a fresh and empty app, but things went from bad to worse. This is what happened:

  • I created a new app
  • I gave it a name, an icon, and a label + a button on the start screen, just to see if the app starts.
  • Then I made an iOS download and installed the app (iPhone 6S with iOS 13.6)
  • the app icon is now visible on the “desktop” of my iPhone (is it called desktop? don’t know)
  • opening the icon shows a whie screen with no icon at start, and the app is also not running.

I uninstalled the app, and made a fresh install. Same result, no splash screen, no app.

Strangely enough: I opened with double clicking the home button the list of running apps and can see, that my app is running, but with another icon! The name is correct, but the icon in the task list is the icon from the app that was downloaded before.

The icon is a png, without alpha, without special chars, 192*192px.

I attached it here: icon_passagen5_ohneT

Any idea?

Hi @domhnallohanlon, and even worse: some minutes ago I made a download of an app that used to work before. This app is no toy, I developed it for professional reasons and now it does not start when downloading it on iOS. I’ve changed nothing, the app is present in the stores, and right now I am not able to test it by downloading it.

Any help is gladly accepted, especially fast help… :smile:

Hi all (@domhnallohanlon), this issue is not solved. The app icon does not show up during app start (iOS), we see only a blank screen (iOS download / live app test), I would call it an error.