Missing custom ios app icon

Good day.

I started working with this great tool just a few weeks ago. I just made a simple thunkable ios app that just opens a website when screen loads and / or when clicking a button. I tested with thunkable live and works ok. I went to the app properties and filled app name and uploaded a 150x150 PNG icon. When i install the application in my iphone it doesn’t show the icon i uploaded, just the beaver icon instead. What did i do wrong?

Thanks in advance for your support.

Reginaldo Bray

Have you taken a look at the docs to see if you’ve done something wrong?

Yes sir, i did.

I double checked to see if the same file is in “files” tab but that is not the case. Screenshots:

I had the same file in “files” tab but i deleted it to upload it in ios app settings page.


Did this happen to someone else here or am i the only one with this issue? :pensive:

Thanks in advance.

Have a look:

Ok, it was solved. Here the details in case it happens to someone else:

I closed thunkable, deleted cookies, files, etc from google chrome. Opened thunkable again and then, for some reason, the icon file in the “files” tab reappeared again. I can’t deleted it, so i renamed it and then filled again the app name and uploaded again the app icon.

After that, i downloaded the app in my iphone, installed it and woilá!, my custom icon appeared.

I don’t know why i cannot delete the file, i click the trash icon, accept to delete but nothing happens. Anyway, the first issue is solved.

Thank you community.


Reginaldo Bray