Error when downloading IOS app

I’m having trouble when downloading the IOS app, I will always receive an email saying that the app has not build. I already changed the app icon according to the size and it still gives me the same error.

This is the error:
“No such object: thunkable-x-production/users/59ddbc7d4f9a5b00017cc57f/projects/5b13bceb44eb57000181baf1/assets/5b4251201046c91586925eac”

I’m out of ideas on how to solve this problem, so any guidance to help me solve this problem is appreciated. Thank you in advance!

Have you seen the information on iOS download problems at

If you delete the icon, the application builds?

How may I delete the app icon? I’ve been searching everywhere on the page!

Good question! I just saw that it’s impossible to remove the icon :slight_smile: Is your icon exactly consistent with the recommendations?

Can you send me this icon file?

I have been using 1024 x 1024 size icon, although I’m not really sure if it’s about the app icon or the png related image. When I tried to download for Android app it says this “App Download Error: Not Found”

I’m a little confused. First you wrote that there was an error while assembling under iOS, and now write that the error message occurs when loading under Android? Or does the error occur both there and there?

I had an opinion that as an icon, you are using an inappropriate image format. Try changing the icon with another icon in the correct format.

I tried to download on both side of the platform but none worked. when I’ve deleted a .png image it shows another error when I tried to build IOS app, this is the error: “Cannot connect to” . Aside from that, how may I know if the icon I want to use is the appropriate image format? Thank you!

Is this application in Thunkable Live all working well? Can you give me a link to it?

Yes it’s working really well in Thunkable Live! Unfortunately it is a private project and I cannot share it publicly…is there any other way to share it privately?

Try this icon.


It seems to me that the problem is not with icon.

Thank you for the app icon! but now when I tried to generate link to share it says “Share link generation error
Error creating share.” . And when I tried to make a copy it gives me this error “Save copy error
Problem communicating with server. HTTP status: 500, server message:”

Restart the Thunkable X development environment

Solution is try PWA or just buy a a template if you looking at simple app like webviewer. Thunkable is not ready for anything proper… It just doesn’t work and there is hardly any tools you can use for any meaningful project.

Even their own showcase app are rejected by iOS.

same here… What could be the solution. please guide.

Thunkable support team did it for me, Thank u very much, my work is safe and I am happy now… Thanks a lot…

Hi, I have the same problem with my project

I have a thunkable Pro account , and my project is

I have errors copy, sharing or downloading my project

also when trying to share have this error

No such object: thunkable-x-production/users/5c1a1fab853d59bc66879fc9/projects/5c3da302dc3434ff4f6ea072/assets/5cb31b68d4a05e833e14b022


unfortunately, I do not have a solution for your problem. Do you have this error recently? Did this project work normally before?

Do you have a copy of this project that works? Unfortunately, in Thunkable X there are cases when the project breaks down and you have to start all the work again.