[Solved] "Made with Thunkable" branding briefly appearing/disappearing in PRO (iOS 13)


I have following problem: on Android the “Made with Thunkable” splash screen on start is replaced with the app icon but on iOS it will always show both… Pretty annoying concerning that one pays to have it removed :confused:

Any way this is fixed soon?

Cheers, Chris

Hey @Chris,

I just created a project on my PRO account, changed the default icon, and installed it on my iPhone.

When I open the app on my device the Thunkable branding has been replaced with the new icon I uploaded - can you share any more info to help diagnose?


1 Like

HI @domhnallohanlon,

here’s a gif that shows what happens. In this example the branding is shown quite short but it also happens to take longer some times. However the Thunkable branding should be completely gone when it is built with PRO, right?

I am using an iPhone 11 Pro and iPhone X with both on iOS 13.

Best, Chris

Aha - yep, it’s very subtle but it shouldn’t be there.

Can you open another Github issue for this and include this GIF too?




@Chris this is related to this long standing iOS issue https://stackoverflow.com/questions/33002829/ios-keeping-old-launch-screen-and-app-icon-after-update. A while back I made some improvements to try and bust the iOS splash screen cache, but perhaps something has changed. I will look in more detail to see if I can’t improve this situation more. The good news is that when you publish it your users should not see Thunkable as they will never have had our logo cached with your distinct iOS package name. If you publish your app and then download it from Test Flight (and haven’t done so yet with our logo) you should see what your users will see. Also if you follow the steps to try to clear out your iOS cache you should not see it and that is what your users will see since they never had a copy with our logo. I realize this is confusing, I will try and improve. Let me know what else you find and if you have any questions, thanks. Long story short it shouldn’t block your publish of the app.


Thank you for pointing that out :slight_smile: Installing the app on testflight the „made with“ logo is gone. I wonder if this problem would also persist if I changed the icon of an already published app? Or when one publishes an app with „mwt logo“ and upgrades to PRO later?

Sometimes I really wonder how Apple does not realize or get rid of certain bugs for such a long time - I mean they have hundreds of developers :sweat_smile:

Best, Chris


@Chris I worked on this some time ago and thought I had found a workaround for this Apple bug that dealt better with the use cases you’re describing. But, now, based on your report, I’m not so sure. Please keep us posted as to the conditions under which you see this behavior as it’ll be helpful when we revisit this. Thanks again for your report.