I have a screen with a listviewer that will display a filtered list of airtable. I tested calling specific column and it works, the problem is not the link of the airtable. But when I use “getallrows” to filter later, but it doesn’t work, it goes to the white screen.
Is it due to the size of the list? (+170 items) or something else?

It’s the size

1 Like

Did you tried just calling the airtable get all rows block and just put a label with the error block? Like a simple test to see if there is any errors with that call?

When this kind of problems happen to me (a white screen) I usually troubleshoot it by going really simple and then slowly adding blocks to it, to see what it’s exactly broken.


That works!

I tried to add block by block and apparently it’s the size of the list.
Any idea?

Mmmm perhaps you could try to ask for the first 20-50 items, with a for loop and the get column block. Then you add one by one as the last item in your list viewer to see what is the limit changing the variable you set to iterate over, x = 20 or 50.

Seems kind of tedious but maybe its a workaround solution :slight_smile:


I solved it by dividing the list. now what hangs is that when the item is clicked on the listviewer it should open the value in a video, but it will not ¬¬ ’