Why is my listviewer not displaying my airtable columns and rows?


I am very new to Thunkable. I have watched many videos and read many discussions, but couldn’t seem to figure out why my table is not showing. I only need to display the data from the airtable, that’s all. Hope you can help with this. I am in a time crunch and need to figure this out!


1 Like

I have done my code exactly how the thunkable docs (https://docs.thunkable.com/spreadsheet) showed it.

you picked the wrong component to add to your screen. you defined your data in airtable but you seem to be using firebase. remove the firebase component from the invisible components and drag in the airtable component. THEN higlight that component in the screen then go to the properties panel on the right and populate the fields APIKey, BaseId, TableName and GridName, which you obtained when you defined your data at the Airtable site.

Hey @fearlesscodegirls3 :wave:

Do you have a share link or screenshot of the blocks you are using? Are you sure you’re interacting with the database? Can you send it data?

thunkable pic

Here is a picture of the code. It keeps resulting in an error and just takes me to the error page.

Thanks for the response!
I have not used the firebase component in my app, and I double-checked. I just followed along with the thunkable docs website. It isn’t used there, either. I have this airtable in the invisible components section. I also populated the fields APIKey, BaseId, Table Name, and Grid Name with the data from the airtable site in the properties panel.

Can you try this then. In the else
part of your block above can you replace navigate to screen 2 with set label# to error (the green error variable). Hopefully it will tell you the actual error.

See this example for how to properly get and display data from airtable in a list. You’re on the right track.

I’d suggest reentering your api key, base id, table name and “Grid view”


Okay, I tried that!
This is the code:code to capture error message

This is the live test:

Seems like the table name is wrong. Try a name with no spaces. All lower or all uppercase. Keep it simple. “table” for example

Thanks for the help! It turned out that the name was wrong. I fixed it, and there doesn’t seem to be any error, but the screen just goes blank.Here is the data in the airtable I am using:

And here is my design for that screen:

i dont think you can populate a listviewer with the contents of the full row, which appears to be what you’re trying to do (ie. get rows, splistviewer, etc). typically, you populate the listviewer with one name, in this case, one column from your table. please try to change the getrows to getColumn (Name) - and populate the listviewer with the returned column.
then in your listviewer on select block, use the returned item for reading (ONE) row to obtain the remaining columns (website and address) if needed.

OR, after doing the getrows, then do the getColumn, upon listviewer select, obtain the rest of the row information by using the index returned by listviewer, as the index for retrieveing from the list initially returned by getrows. (does this make sense?)

1 Like

you extract the value (contents) of the object (the row) property (the corresponding column in that row) with the blocks as shown

Screen Shot 2020-05-02 at 4.40.15 PM

i also always put the data into a variable first. just out of practice.
Screen Shot 2020-05-02 at 4.41.45 PM

1 Like

Thank you, this helped a lot!


Feel free to mark it as a solution if it was. It will help other thunkers searching through the forum!

Happy to help!

1 Like

I can see my data on the desktop live version, but not on a phone. Am I missing something?

Hmm. Want to share a screenshot of the code?

Here it is:

Also, if you wouldn’t mind, I have a few questions:
How can I make breaks/‘enter spaces’ between the values of my data? I only decided to make one column of data (with all the data I need) with extra rows in between and on the live version this is how it appears:

Is there any way to hyperlink websites aside from using a button? I know there are HTML ways but on my listview’s property panel I just cannot seem to find where.

Thank you so much for your support!

Hey! Ill be making a video about this soon. Id use a custom made list viewer for this.

There’s an example of that here

And here

1 Like