Video Recorder in "Snap to Place" vs "Drag and Drop" projects

Hello!

I hope you are having a good day.
I just had a quick question. So all I want to do is record a 10-second video to upload to an external server.
However, my project uses the “Snap to Place” interface which when testing the video recorder just to record a 10 second video the app says “Something has gone wrong. Check your blocks and reset this page.”
This is the image of the blocks I used for “Snap to place”
image

When I use the “drag and drop” interface the video recorder works fine. Here is the block diagram:
image

Note, I am using a Samsung S21 Ultra to test the app on and I checked my permissions.
If you have any suggestions as to why the video recorder is working on the phone with “Drag and Drop” Interface but not on “Snap to Place” that would be greatly appreciated.

Worst case. I will just have to redo the whole app using the “Drag and Drop” interface.

Thanks,
Andrew

Welcome to Thunkable!

Try putting a “wait 10 second” block between the one of the blocks… Does that help?

Have you tried switching play and select file? it looks like your calling the file to play before telling it which file.

I tried that It still gives the error “Something has gone wrong.” I am just going fork over everything to a new project.

Try this @andrewpalmertree

I just tried that and still get the same error message. It works fine in the web browser but not on my phone for some reason. I might try it on a different phone and see if it’s just my phone having issues.
Thank you for the help. It’s much appreciated!