Text to speech not working

i have a prayer app a list of prayers set to play from data source all other prayers play except for one on Android I don’t know how to fix this is it the length of the text the spacing? I don’t know
Any ideas anyone

2 Likes

I am using Airtable as a data source can someone plz let me know why tech to speech don’t work on Android for a couple of my prayers i am using free program do i need to upgrade airtable or something

1 Like

Hey @Mikas_3D - in this case, is it playing all except the first or the last one by any chance?

It sounds like perhaps there might be an issue with the loop you’re using - can you share a screenshot of what blocks you’re currently using?

Thanks!

i figure out i may have too much text for android i am going cut the text in half seem to play that way.

it such an annoyance to chop the text up in 3 different screens is there a way to increase the word count for text to speech to read in Android

You won’t need multiple screens for this @Mikas_3D - a list of paragraphs will take care of everything on s single screen.

When the first paragraph finishes, move to the next paragraph.

My app has already been publish with thousands of user i did not feel like having to update the version to fix this but i might have to

Also strange thing happen i deleted the airtable data base from project and it stop working in the published APP only started back working when i re ad the database how is that possible

Updating your app is a pretty simple thing to do in both Google Play and on the App Store. It’s something you should do regularly to make sure that your users get the best possible version of your app. For example, we update our own app every week or two, so updating your app once a month or so shouldn’t be too big an ordeal.


If you deleted you app’s database then I would fully expect your app to stop working.

i deleted the database in the project why would that delete it in the published app

As for updating i have to do 5 updates in 4 days the APP users is annoyed. hopeful i dont have to do anymore.

Me again Text to speech not playing on ios test any app and see or is it just me

@Mikas_3D - i tried this on iOS live testing and it worked perfectly for me.

Are you using a label to help you debug this? (I’m assuming that there’s some sort of issue getting the text that you are then sending to the TTS component)

it’s working now

1 Like