[Solved] Text-to-Speech and Speech Regognition Stopped Working

All of a sudden, all of my Text-to-Speech blocks stop working. I get no voice responses. Yes, my phone is on and it is not on salient.

Also, the Speech Regonition is returning an 203/Corrupt error then the app aborts.

Thanks.

2 Likes

Hi there,

Have you tried building simpler apps to test these components?

This app uses both Speech to Text and Text to Speech components and doesn’t encounter either of these issues.

Hey all. I’ve experienced text-to-speech stopping to work on my Android devices one after the other so at points in time I had it working on one device but not the other and a couple of weeks later having the same issue on both. This was an indicator that there was nothing wrong with my app but rather something being wrong with my devices. So after a bit of searching I realised that it was the Android text-to-speech offline file being corrupt, not just for my Thunkable app but any app that was using text-to-speech on my devices.

In my case it was fairly simple to understand the problem as I am using tex-to-speech for Greek so I found out that by navigating to Settings > Smart Assistance > Accessibility > Text-to-speech > Tapping on the (i) on the top right > Install voice data > Greek (in my case) and tapping on Voice I was giving me an error. So I tapped on the trashcan icon next to the downloaded file entry, tapping “Uninstall” and then re-downloading the language pack solved the issue!!!

So my question to the Thunkable team (@jane) is if there is any Thunkable could be breaking the text-to-speech file on the Android device. My assumption is that it can’t but on the other hand, the only way this could happen on both my Android devices is if Google actually pushed a broken update to the language which would again be questionable since my devices stopped working with about 2 weeks difference.

In any case, I am happy to share my solution for anyone experiencing the same issue.

Konstantinos

1 Like